Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #22008

    Hello,

    Frontpage pagination is not working : when clicking on page2/3/4/etc it is just reloading the front page and not displaying older entries at http://www.coco-sound.com, when clicking on blog : http://www.coco-sound.com/blog/ then it is working back.

    Anybody have an idea of what is going wrong

    Thanks

    #113896

    Hi hipisland,

    Couple of things to try: First, disable all active plugins just to make sure there are no conflicts. Second, try changing your permalinks to default in Settings>Permalinks. If that fixes the issue, you can try switching them back to your previous settings. If that doesn’t work at that point however, you can try going through the troubleshooting tips for permalinks here: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Regards,

    Devin

    #113897

    Hello,

    I have tried both of your solutions : changing permalinks parameters

    and tried the plugin solution but unfortunately even with all plugins deactivated : still some problems.

    Also : when clicking on : http://www.coco-sound.com/en/ (english home of the site)

    some error appears : Warning: extract() expects parameter 1 to be array, null given in /home/kokkosou/public_html/coco-sound.com/wp-content/themes/shoutbox/includes/helper-templates.php on line 228

    could it a starting point of an explanation?

    #113898

    What plugins do you have active? If you have any caching plugin, you’ll need to completely delete it from your plugins folder to keep it from effecting the site.

    When you changed the permalinks to default, the pagination still didn’t work?

    Regards,

    Devin

    #113899

    I have the same problem with my site (http://tagandjuice.com.br). I tried to change the permalinks and the problem still occurs.

    This issue happens only when the a page was selected as a homepeage on the theme options. When I accessed the page directly, the pagination works fine.

    Best regards

    Rodolfo

    #113900

    I have found some kind of solution and, by the way, with or without extensions activated this does not change anything:

    In wordpress > reading settings : set to default = latest posts

    In theme options : Frontpage Settings : for homepage : my selected homepage + for blog : my blog

    And so far it works, well… at least with my main language (french) but does not with my english version ( I use WPML) where I do still have some weird behavior :

    homepage in english is not displaying the theme template, but a regular blog template + when clicking on the logo (home) it is still displaying this : Warning: extract() expects parameter 1 to be array, null given in /home/kokkosou/public_html/coco-sound.com/wp-content/themes/shoutbox/includes/helper-templates.php on line 228

    @ rodolfo : may be this could help you?

    #113901

    If the issue still happens when permalinks are set to default then the issue is with wordpress/server. You can try the troubleshooting tips posted here in the codex: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Regards,

    Devin

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Front page pagination not working’ is closed to new replies.