Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #22942

    I’m using Replete with a frontpage template that calls for a right sidebar. I have been unable, though, to get widgets into that sidebar…the only widgets that show up are the ones I have set to “Display everywhere”, which is not what I want. I’ve tried two things: adding them to the Frontpage sidebar, and creating a new sidebar for the page, Welcome, that is my front page, but nothing I put in either play shows up on my front page. I must be missing something simple cuz no one else seems to have this problem…i just can’t figure out what it is.

    I’ve seen the instructions for forcing a sidebar beside products or adding a mulit column area with widgets, but that isn’t what I want, either.

    My site is Thanks!



    The Force Sidebar only uses the Displayed Everywhere widget area. Please try to use Widget Logic to control the Displayed Everywhere sidebar.





    I’m not using the Force Sidebar.

    I’m going to Frontpage in the Template Builder, selecting “right sidebar” in the first pull down. That’s all.

    I would have that that sidebar was then handled via the “Frontpage” widget area, no? But nothing that I put there appears. And on top of this, when I put widgets in other area, like all post pages or whatever, THOSE show up on the front page, as well, for no clear reason at all.

    BTW I do know how to use widget logic, I just think this is weird.

    Something is definitely not working right here. Maybe I have to go through yet another round of turning off any plugins, see whether the sidebars start behaving correctly.




    Please send me the login details to sighlence13[@]hotmail[dot]com. I would like to check the frontpage.

    Include this thread on your email. :)





    It seems that the sidebar widgets is not working properly with the dynamic template. I created a new dynamic template just like the Frontpage and selected right sidebar. After that I created a new page and applied the new dynamic template to it. On the Appearance > Widget > I applied the widgets on Frontpage widget area then removed widgets on Displayed everywhere widget area. Lastly, go to Theme Options > Frontpage settings > select the new front page.




    Hi Ismael,

    Did you actually do any of this within the site? Because I just tried it and it didn’t work. I created a new templated named “frontpage2.” I created a new page named “frontpage.” I assigned the frontapge2 template to it. I assigned the widgets to the frontpage. And I selected frontpage as my home page in the Replete options. (I haven’t redone the slideshow on the new page yet, don’t see the point until I get this working.) I did everything in the order you said, and it didn’t work.

    If you are doing all of this in my site, just leave what you are doing in there and tell me where you put it, cuz when I do it, I’m not getting anywhere with this, at all. All I’m getting in my home page sidebar is the item that is set to appear on the blog page sidebars, the meta info. I put there for testing, basically…nothing else.



    You are missing a css file from one of your plugins go_pricing ->


    Please update, the latest theme out is 1.41


    The sidebars need special care. Do this. Create a custom widget area in Replete > Theme Options > SIdebars for the frontpage calling it -FrontPage 2.

    Do not add anything to Frontpage2 but add a text widget to each of the following 3 sidebars/widget areas: ( dont forget to save each widget after adding it) – Pages, Everywhere, Frontpage. Make sure each of those 3 widget areas has just 1 text widget (you can put title of the widget area into each of the text widgets so that on the website you can see which area is showing up.

    In the beginning , only the Pages and Everywhere will show up on the live site, while Frontpage widget area will not show, and Frontpage2 has no widgets yet ,so doesn’t show up also.

    Now from only Everywhere sidebar, remove all widgets (should be just text widget) . So now on the front you should have only Pages widget showing (Everywhere and Frontpage2 have no widgets, and Page and Frontpage has 1`text widget in each, but Frontpage not showing up)..

    Add a search widget to FrontPage2 sidebar (the one you made) and save. Now you should see on front of the site the Pages sidebar and the Frontpage2 sidebar. Remove the text widget from Pages sidebar and all you have is Frontpage2 sidebar showing the search widget alone. Just whatever you do, DO NOT take off the very last widget from a custom widget area, If you need to change it, first add a new widget and then remove the old one.

    The Frontpage sidebar never did work when I tested it now.

    Yes, I did all this and it works.

    If you dont want to do this, just install this plugin, and it will take care of everything else

    I dont know why this happens sometimes. I think its a good idea to first warm up widget areas.



Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘front page sidebar’ is closed to new replies.