Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #9102

    Hi,

    I’m using SEO by Yoast for my website. However, I noticed that there is no way to customize the frontpage SEO settings. In Angular, I have set the frontpage to be “portfolio”, and I have already set all the SEO settings for that page. It works out fine when you click on the actual “portfolio” page, but if you just go to the home/frontpage, the settings are no longer there. The title of the page is reverted to what I have set in “general settings”.

    How could I work around this?

    #63493

    Hey,

    in header.php replace:

    <title><?php bloginfo('name'); ?> | <?php is_home() ? bloginfo('description') : wp_title(''); ?></title>

    with:

    <title><?php wp_title(''); ?></title>

    #63494

    Hey Dude, tried that, but it doesn’t work. Same thing. Any other ideas?

    #63495

    your missing ´´…. should look like:

    <title><?php wp_title(”); ?></title>

    #63496

    Tried that – didn’t work neither.

    http://thefifthorder.net/wp/

    I have the SEO title for my portfolio page set to:

    Jeff Huang — Art Director & Illustrator | Illustration & Design

    but it’s showing up as this on the homepage

    Jeff Huang — Art Director & Illustrator | Illustration -

    #63497

    I actually just changed the title in my general settings to prove that it is indeed not working.

    http://thefifthorder.net/wp/

    You could see it there.

    Again, in angular, I have my frontpage set to my “portfolio” page, and in the portfolio page, I have the SEO set to:

    Jeff Huang — Art Director & Illustrator | Illustration & Design

    I must fix this since this is the homepage…

    #63498

    It’s an issue with the seo plugin then because it hooks into the wp_title function. You can try to deactivate the seo homepage title output and use the standard code instead.

    @hectortarifa – thanks for spotting this. I corrected the code.

    #63499

    Fixed it -

    Turns out I had to go into General Settings -> Reading, and set the frontpage manually to portfolio instead of “latest post”. Now it works.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Frontpage SEO Settings?’ is closed to new replies.