Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #186803

    Hello,

    Can you please help with the following?

    The slider on our homepage only shows the first two slides of four. Text/buttons do not display on slide 1 and those buttons that display on slide 2 do not work.

    I cannot determine when this started happening unfortunately, only that my client reported it to me today.

    I see the following in WP debug.log :

    Undefined offset: 2 in /var/www/webadmin/data/www/ski-mobile.com/html/wp-content/themes/choices/framework/php/function-set-avia-backend.php on line 384

    The site is ski-mobile.com

    Any help you can give me would be greatly appreciated.

    #186909

    Hi robinmannering!

    Please update your theme to the latest version. You should login on ThemeForest with the account you have purchased Choices and go to Downloads to download it
    For a quick guide on updating your theme take a look at this video on updating the theme via FTP: https://vimeo.com/channels/aviathemes/67209750
    Cheers!
    Yigit

    #187173

    I have the same problem; did not check the debug.log file .
    It may be a coincidence but I just updated to WP3.7.1.

    #187326

    Hi!

    @mcvlot which version of the theme are you using? If it is not the latest, please try to update as well ( see video tutorial on updating via FTP in my previous post please )

    Best regards,
    Yigit

    #187377

    Hello Yigit,

    The problem to quickly update is due to the patches I have applied to the original theme.
    It will take me several hours to do all the careful checks to make sure I apply all of them
    properly to the new version.

    Note: currently I am on version 1.7 of Choices, I should move to 1.9 I guess.

    Note: why do you advice FTP updating: can’t the theme update itself through the usual wordpress mechanisms.
    For a plugin I bought that works fine. Of course my patches need to be reapplied: should I create a child theme?

    Regards, Marnix

    #187732

    Hi!

    @mcvlot Yes, you should update to version 1.9. You can see this video tutorial that Devin prepared on how to create a child theme http://vimeo.com/channels/aviathemes/67221517

    Best regards,
    Yigit

    #192847

    Hello there,

    I have installed (hopefully correctly) version 1.9 of the Choices theme.
    Did this by downloading 1.9 to my server in a new directory, reapplying all patches
    and renaming the new directory to “choices”. Reapplying the patches was
    a lot of careful work – though they are quite small it is non trivial to reapply them.
    A child theme would not have been a good solution either

    The website seems to work, but the slider still does not.
    Herewith a screenshot of the Javascript error I get on the chrome console.

    https://www.dropbox.com/s/552so92xxpsv0uy/Error.png

    Regards, Marnix Vlot

    #193346

    Hey!

    The wp-ui.js script is not a theme file and I guess a plugin causes the js error. Try to deactivate all third party plugin and check if this solves the issue. If yes activate the plugins one by one to find the culprit.

    Regards,
    Peter

    #193540

    Found the violating plugin: WP UI (that was an easy guess). Silly interaction with the JS driving the slider. Sorry for bothering you.

    Regards, Marnix

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Frontpage Slider Problem’ is closed to new replies.