Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #9352

    I noticed that only the summary of a blog post will appear on the RSS signup page in Firefox, whereas in IE, the entire post will appear. Is there a way to force the entire post (not just the short two-line text summary) to appear in the feed in Firefox, too?

    #64430

    Hey,

    go to Settings > READING > SYNDICATION FEEDS and select the “FULL TEXT” option.

    #64431

    It is indeed already set to “Full Text.” Still not seeing the full text, though.

    #64432

    Strange – maybe this plugin: http://wordpress.org/extend/plugins/full-text-feed/ will help you.

    #64433

    Still no luck. It should have been solved by the Syndication Feed settings, as you first suggested, because there aren’t any <!–more–> tags. But it still isn’t showing full posts in Firefox for some reason.

    #64434

    I also tried switching the Feed settings and then testing in IE, which responds correctly by displaying either the full posts or summaries as appropriate.

    #64435

    I think it’s a Firefox issue then. Obviously it shortens the feed text by default. Probably a server side solution: http://devilsworkshop.org/force-firefox-to-display-your-full-feeds-wordpress-hack/

    #64436

    That seems to have done the trick. Many thanks!

    #64437

    Glad that I could help you – Status set to resolved.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Full Post in RSS feed’ is closed to new replies.