Tagged: ,

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
  • #201078

    Hi, my homepage features a fullscreen slider. Till updating an hour ago, one of the slides lookd like this: http://i.imgur.com/Vo1VpKF.jpg
    I made it without a title, only html text: http://i.imgur.com/bb9w7K9.png
    With the last update the slide only reads: “array”: http://i.imgur.com/MLyxiNn.jpg

    However, when I open the element to edit it, nothing has changed: The same text is written as before, with no title. Dont understand why its not working the same as before


    This reply has been marked as private.


    The fullscreen slider will now default to background position: 50% 50% or center center. You can modify the full inner slider position using this on your custom.css or Quick CSS:

    .avia-fullscreen-slider .avia-slideshow-inner li {
    background-position: top center !important;

    Don’t remove the !important property. Can you please post the html code that you added on the slider?



    Here’s how i see it right now:



    Mmm no, it is working but not as before… I had to make changes I didnt want to do.

    Before update, the text was working as a link, and I had an icon (an arrow) pointing down that scrolled to the next section. See http://i.imgur.com/Vo1VpKF.jpg
    That was very useful in the fullscreen slider to let the people know they can scroll down.

    Now I cant have them anymore! I tried to make the text or the icon to work also as a link and all I get is “array”: http://i.imgur.com/MLyxiNn.jpg

    You may try it yourself with the code I posted before.


    Another thing is that the text I’m using as a title isnt animated ;(

    Just to let you know, for the title of the slide you posted I wrote:
    <br /><h1><span style=”color: #ffffff; text-shadow: 2px 2px 2px #000000;”>VOLUNTARIOS POR UN DÍA</span></h1><br />



    Can you please create me an admin account and post the login credentials as private reply – I’ll look into it.

    Best regards,

    This reply has been marked as private.
    This reply has been marked as private.

    I think you could also consider adding a scroll-down-for-more icon option for fullscreen slider.
    Any user that visits the site for the first time may think that the site finishes at the bottom of a fullscreen slider.

    This reply has been marked as private.


    I can’t reproduce the issue. I replaced the title of the second slide “VOLUNTARIOS POR UN DÍA” with your html code

    <br /><h1 style="text-align: center;"><a title="Voluntarios por Un Día" href="http://universitarios.org.ar/voluntarios-por-un-dia/"><span style="color: #ffffff; text-shadow: 2px 2px 2px #000000;">VOLUNTARIOS POR UN DÍA</span></a></h1><br />

    and it works and I don’t get the “array()” error. Please note that you can’t use a link for the title if youz already applied a link to the entire slide/image (that’s why I removed the slide link from the second image). The reason is that you can’t add a link to a link and if the image/slide is already a link the caption/title is also part of the link and mus not be a separate/different link.

    The icon shortcode changed with v2.4 because we introduced a new icon builder. You need to regenerate the icon shortcode with the shortcode builder (magic wand icon > “Icono” option) and then insert it into the slider caption field.

    Best regards,



    Wait, I found an issue in the slideshow code which will prevent it from executing other shortcodes. I debugged the issue and we’ll fix it with the next theme release. I modified some theme shortcode files on your server. Please upload the unmodified theme files (all files in enfold/config-templatebuilder/avia-shortcodes) to your server to revert my changes.


    This reply has been marked as private.

    Ok, it’s back.
    Hope you can fix any bug with next release!




    Yes, if you need a quick fix open up /wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow.php, /wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullsize.php and /wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_fullscreen.php and replace

    'content'		=> ShortcodeHelper::shortcode2array($content)


    'content'		=> ShortcodeHelper::shortcode2array($content, 1)

    Note: I already applied these changes to your files.

    Then clear your browser cache and reload the slider page. I noticed that your server seems to cache the content somehow and you maybe need to wait some minutes until the changes take effect.


Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.