Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #246211

    last time i tried to change the functions.php file with the following code

    add_filter('the_posts', 'bump_sticky_posts_to_top');
    function bump_sticky_posts_to_top($posts) {
        foreach($posts as $i => $post) {
                $stickies[] = $post;
            return array_merge($stickies, $posts);
        return $posts;

    it just broke and started to give me the following error upon access:

    Warning: require_once(config-wpml/config.php): failed to open stream: No such file or directory in /home4/aum/public_html/wp-includes/functions.php on line 29
    Fatal error: require_once(): Failed opening required 'config-wpml/config.php' (include_path='.:/opt/php55/lib/php') in /home4/aum/public_html/wp-includes/functions.php on line 29

    any suggestions how to make it work? the website url is:


    Hi akhilz!

    Please insert the code into wp-content/themes/enfold/functions.php and not into wp-includes/functions.php.

    Best regards,


    thanks Peter

    have done as directed.

    works on one of the pages:

    but not on the homepage as yet:

    please help.



    Yes, it’s weird. Unfortunately sticky posts won’t work properly with the category__in query parameter – see:

    I suggest to try a plugin like: – it enables you to change the sort order of the posts easily and you can use it to add your “sticky posts” to the very top.



    hi Dude
    i was working on something else entirely and changed the Blog Style back and forth with Multi Author and Single Author styles and somewhere along the line i realized that sticky post has started working on the home page as well. strange but it happened, check
    am not code friendly so wouldn’t know what made it work, informing you so others may be helped!

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Sticky Posts Not Working’ is closed to new replies.