Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #11904

    I started working in theme yesterday with no problems, however today I tried to “import dummy copy” to see how things were done on the example site and now when i try to go to my site, I get this error message:

    “Internal Server Error

    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    Apache Server at junkpowder.com Port 80″

    I called my hosting provider and let me know that it was a them problem because when I disable your theme, my site appears again, but only without the Flashlight look of course. And when I activate the theme again, the website gives me the same error message.

    Please let me know how to fix this. This very urgent.

    Thanks

    -Jaun Mims

    #73526

    As I play with the site, it seems that the woo commerce plugin is causing the problem. When I deactivate the plugin, the site comes back, And when I activate again, I get the error code. Please let me know what to do for I do need the Woo Commerce plugin to work properly in order to sell products.

    Thanks,

    Jaun Mims

    #73527

    I have the same thing and I don’t want or need WooCommerce. I had the 500 Internal Server Error both from Google Webmaster and web-sniffer.net. I looked at the error_log file and found the following:

    [28-Apr-2012 22:47:36] PHP Fatal error: Call to undefined function __() in /home4/hosinski/public_html/wp-content/themes/flashlight/framework/php/class-tgm-plugin-activation.php on line 124

    I tried to fix it by installing and activating the plugin as directed by the theme. This did nothing. I deactivated the theme and the error remains.

    I also have a Google Webmaster “ver” URL parameter issue for a WooTheme (estate) that has long since been removed:

    wp-includes/js/jquery/jquery.js?ver=1.7.1

    wp-content/themes/estate/includes/js/woo_tabs.js?ver=3.3.1

    I cannot get google to crawl my site at all. Period.

    I’ve tried Yoast SEO for WordPress But that’s not the problem.

    Something is blocking Google bots from crawling and reporting.

    Webmaster says it can’t access robot.txt

    Besides the one 500 error there is another server error that it says it has but it’s not listed.

    AdWords works somewhat.

    I’m on day 4 of trying to get the most fundamental, tiny, search query to work on google.

    Bing works.

    Many thanks

    Hope my error log helps

    #73528

    @jaunmims please provide an error log like lhosinski – 500 is a general error and it doesn’t tell us what’s going on.

    @lhosinski please try to generate a robots.txt file by using tools like: http://www.mcanerin.com/EN/search-engine/robots-txt.asp and place it in your main web directory (where the wp-content folder, etc. can be found).

    #73529

    Hi Dude,

    Thanks for the reply

    I used Yoast SEO for WordPress to generate the robot.txt file.

    robots.txt file is in the lowest level .

    /public_html/robot.txt

    So here’s the file:

    http://www.hosinski.com/robots.txt

    I’m going to download the theme again and replace the file:

    class-tgm-plugin-activation.php

    This is what’s reported as a Webmaster server error 500 although the digs say there are two.

    The boxes at the top of crawl errors for DNS, Server Connectivity and Robot.txt Fetch all have green checkmarks

    BUT, if you hover on them

    DNS indicates “Couldn’t connect with the DNS Server”

    Server Connectivity indicates: “Request timed out or site is blocking Google”

    Robot.text Fetch indicates: “Crawl postponed because Robot.txt is inaccessible”.

    N.I.G.H.T.M.A.R.E.

    I’ve been in IT since the internet only went to DARPA and universities. DEC PDP11′ COntrol Data Cybers. UNISYS, IBM AS400’s luggable Compaq’s One of my bosses made the Kenbak-1 Mozilla had Godzilla in the upper right corner. I’m an antique I can build an exchange server and SQL. I had my Cisco CCIE But I can’t figure this cr@p out.

    It’s like a Rubics cube. (Never able to complete one)

    That said I have some “pshyc” issues that make this stuff very difficult for me. I start down one path then another, then I can’t figure out what I was trying to do in the first place. My mind is toast.

    I’f I need to pay for support, no problem send me a private msg. Or a referral.

    If I need to reinstall. No problem

    Heck, I think I need to change themes anyway to fit better with SEO.

    Thanks for reading.

    #73530

    Update.

    I think http://hosinski.com is Indexed I have no Crawl error when I select that site.

    http://www.hosinski.com produces the errors.

    Should I switch things?

    #73531

    I added an “A” record for http://www.hosinski.com

    Webmaster was saying not in domain.

    #73532

    ALSO:

    wp-content/themes/flashlight/err_log

    [29-Apr-2012 19:38:46] PHP Fatal error: Call to undefined function avia_get_frontpage_template() in /home4/hosinski/public_html/wp-content/themes/flashlight/index.php on line 10

    #73533

    @ lhosinki and Dude. How doe I find the error log so I can provide it to you???? All I know is the site works when Woo Commerce is not activated and doesn’t when I activate it. I have no problems on the WP admin side, only when I try to view my site.

    PLEASE HELP!

    #73534

    Dude,

    Here are some of the logs I’m getting:

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/woocommerce-config/woocommerce-mod.js?ver=1 HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/uploads/2011/09/Tambako_the_Jaguar5_small-200×140.jpg HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/js/prettyPhoto/js/jquery.prettyPhoto.js?ver=3.0.1 HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/js/avia_fade_slider.js?ver=1.0.0 HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/js/avia_fullscreen_slider.js?ver=1.0.0 HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/js/jquery.masonry.min.js?ver=1.0.0 HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/hr.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/shortcodes.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/bg-trans.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/minimal-skin.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/icons-rounded-rss.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/minimal-skin.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/logo.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/minimal-skin.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/icons-rounded-facebook.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/minimal-skin.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/themes/flashlight/images/skin-minimal/icons-rounded-twitter.png HTTP/1.1″ 304 – “http://junkpowder.com/wp-content/themes/flashlight/css/minimal-skin.css” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-includes/images/admin-bar-sprite.png?d=20111130 HTTP/1.1″ 304 – “http://junkpowder.com/wp-includes/css/admin-bar.css?ver=20111209″ “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    66.190.91.147 – – [29/Apr/2012:18:57:20 -0700] “GET junkpowder.com/wp-content/uploads/2011/09/016.jpg HTTP/1.1″ 304 – “http://junkpowder.com/” “Mozilla/5.0 (Macintosh; Intel Mac OS X 10.5; rv:11.0) Gecko/20100101 Firefox/11.0″

    There are tons of them however I don’t really know what you need to be able to help me.

    Please Help!!

    #73535

    Just wiped my site off the map.

    Fresh WP install.

    Going to run twenty eleven with one post for a few days.

    Thanks

    #73536

    Hi lhosinski,

    Let us know how it goes.

    Regards,

    Mya

    #73537

    Thanks May

    So far? Not so good.

    Same problems

    Could it be sub-domains?

    #73538

    Hi lhosinski,

    I just re-read through everything you’ve been going through and it might be a bit late but I would suggest talking with your host about what support they might have for wordpress installations. If they don’t have any advice/additional help, it might be worth it to look into another one as you should not have to have so much trouble with just getting a basic installation to work.

    Regards,

    Devin

    #73539

    Devin,

    I was going in that direction.

    My hosting is Blue Host. Their response is “not my job”

    Could it be that on of the other BlueHost domains that shares the IP is blacklisted by google? Can that happen.

    I put in a “reconsideration request” to google to index my site on the off chance it is blacklisted. The said wait a few weeks.

    However, Webmaster is indexing my site.

    Per Analytics, my last google visitor was May 1, 2012, which was probably the last day my Adwords campaign was active. I thought about your recommendation of not ripping apart the site, but yesterday I couldn’t resist. I changed from having a page with a “menu” to just a Post on the default home. I turned off all responses.

    I was looking for any little nuance. Google said the sitemap should be named “Sitemap.xml” So I did. I used “Google XML Sitemaps” plugin to generate it. Webmaster likes it.

    I’m using Yoast SEO for WP plugin. It’s only active on the one post. Very basic.

    My robots.txt is

    User-agent: *

    Disallow:

    Disallow: /cgi-bin/

    Sitemap: http://http://www.hosinski.com/Sitemap.xml

    Webmaster likes it. I do have 33 blocked URL’s but that number has been there for some time and has not changed.

    Analytics shows my direct links to the site. I have a widget for Total, Google Organic, and Non Google.

    Bing works, but does not show up in Analytics.

    I have 3 visits from kriesi.at Thank you very much !

    Source/Medium Visits

    (direct) / (none) 38

    ask / organic 11

    aol / organic 4

    kriesi.at / referral 3

    comcast / organic 2

    info.com / referral 2

    search.mywebsearch.com / referral 2

    search.rr.com / referral 2

    answers.com / referral 1

    cnn / organic 1

    Visits by Date (Google)

    Date Visits

    20120425 6

    20120426 6

    20120429 5

    20120427 3

    20120428 1

    20120501 1

    Visits by Date (Total)

    Date Visits

    20120426 18

    20120429 17

    20120427 16

    20120425 14

    20120428 13

    20120501 3

    20120503 2

    20120512 2

    20120515 2

    20120516 2

    I believe all the “google” visits came from Adwords.

    So the site has can be crawled like a googlebot, fetched and indexed, show no blocks when robots.txt is tested, and likes the sitemap. But will not show up on a google query.

    I have run 6-8 different DNS tools on the net. CNAME, A, tracerout, whois all work The SOA is out of specification at 86,400 but BlueHost said that isn’t a problem.

    At this point I put it down for a few days then pick it up later.

    Thanks for looking

    #73540

    I hope it works out for you. Its a bit of an odd issue so I’m sorry we have not been able to help much. I’m going to close the topic for now however so that it doesn’t get too complicated with various responses and everything else.

    If you have any issues for support with how the theme works or has bugs, please post a new topic and we’ll address it as best we can :)

    Regards,

    Devin

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Getting 500 Internal Server Error’ is closed to new replies.