Tagged: ,

Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #206360

    I’m getting these errors in the flashlight theme when running the “Google Structured Data Testing Tool”


    Error: At least one field must be set for HatomEntry.
    Error: Missing required field "entry-title".
    Error: Missing required field "updated".
    Error: Missing required hCard "author".

    (im using an old version of the theme, as ive done rather a lot of custom edits to my theme but I just downloaded the latest version and saw that its still missing the attributes for hatom.

    These are the errors im getting with the fixes, I managed to get the “Author” working but could not get the “Title” or “Date” to show in the test.

    Is there any intention of adding these to the theme or would these edits be responsible of the individual users ?


    Hey xGSTQ!

    Please go to wp-content\themes\flashlight\includes folder and add needed strings as explained here http://fivera.net/hatom-feed-hatom-entry-error-wordpress-solution/

    Best regards,


    Hi Yigit

    Before posting this thread I did those edits, as suggested in your link and my link and the only one to work was the “Author” entry

    I made the edits to wp-content\themes\flashlight\includes\loop-index.php

    The “Title” and “Date” entries would not work


    • This reply was modified 1 year, 9 months ago by  xGSTQ. Reason: Typo mistake


    Create a backup of the loop-index.php file then remove everything. Replace it with this code: http://pastebin.com/1zfWDddh



    Thanks Ismael,
    I tried these edits actually myself yesterday.
    I pasted your code (similar to mine except you did each date attribute) into the index-loop.php

    As before the “Author” works but the errors still show for “Title” and “Date” attributes


    Screeny of the “Title” attached, as you can see the “entry-title” attribute is in the class but its not working. I thought it was the cufon so I disabled it, but then again Google doesn’t read much javascript so it couldn’t be that. So im a little lost on this one, hence why im posting for advice



    Have you modified all files these files loop-portfolio.php, loop-page.php, loop-page-mini.php, loop-index.php inside wp-content\themes\flashlight\includes folder folder?



    No just loop-index.php

    Ill edit them in the next hour or so and get back to you




    Sure, we are waiting to hear from you



    Right im getting somewhere !!


    Ive worked out that the hatom errors are coming from the “Related” articles at the bottom of the page as there is 4 sets of errors, and there are 4 related articles :)

    Ill be there in a min

    And for the others, all the edits are in loop-index.php so far, I just had to add the attribute “hentry” at the start of the content

    <div class='post-entry


    <div class='hentry post-entry

    Now to find the related articles, im not actually 100% sure that I should add the “entry-title” attribute to the related articles, or close of the </hentry> </div> class as the related articles are not the main titles…. going to go read up

    —– UPDATE —–
    Ok so it was not the “related Articles but the shop items that I had added to the page

    If you check this link out >> http://www.google.com/webmasters/tools/richsnippets?q=http%3A%2F%2Fwww.jamespictures.co.uk%2F2013%2Fsunset-on-llanddwyn-island%2F Everything is fine

    So the problem is with the woocommerce attached items, which im not to bothered about, I guess that’s another job !!

    So all sorted all done and working, you can use this http://urbanstoic.com/how-to-fix-google-hfeed-or-hcard-warnings or any of the other listed sites to fix the Google Hatom but dont forget to add “hentry” to the opening class.

    All edits were done in includes/loop-index.php

    • This reply was modified 1 year, 9 months ago by  xGSTQ.
    • This reply was modified 1 year, 9 months ago by  xGSTQ. Reason: update


    Glad you figured it out and thanks for the heads up :) Let us know if you have any other questions or issues


Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Google Hatom Errors’ is closed to new replies.