Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
    Posts
  • #26200

    So I am trying to create a press/news section for my site.

    I have created a page (Latest News) and added the blog element from the builder.

    The ‘Latest News’ page resides under ‘About us’ in the hierarchy of the pages and lists all the posts that I have marked as press releases.

    When I click on an article title and go it’s single page the header now reads “Blog – Latest News” and links to my home page.

    How can I change this to remove “Blog” and to point back to the archive for the ‘Latest News’?

    I have tried to create a single.php file and removed the word Blog from the code but it still will not link to the archive page. So what am I doing wrong?

    I also have no blog selected in the settings for the theme.

    #129664

    Hi,

    This happens when the blog is not defined in Enfold > Theme Options . In that scenario, the individual blog post automatically display those words and link to the home page. To change the words and the link you would need to edit 2 pages:

    First get the URL where you want the link to point to, just copy it from your browser then open up::

    single.php

    line 9 and 10 and change them like this

    $title  =  ''My new title';
    $t_link = 'http://your-domain.com/link-to-blog-page/and-a-slash-at-the-end-of-link/';


    index.php

    Lines 11 and 12. Repeat the same exact thing as above lines 9 & 10, can copy the code even from above.

    Thanks,

    Nick

Viewing 2 posts - 1 through 2 (of 2 total)

The topic ‘H1 permalink takes to home page not archive page for posts’ is closed to new replies.