Tagged: 

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #233841

    I’ve got a strange problem on a website I built for a client where users have to double click on a product thumbnail to go to the product page. This is the effect in Firefox, I don’t know about other browsers. I need to fix it though, and was wondering if you might know where I could start looking for the problem.

    I’ve already went through the typical debugging steps disabling plugins, updating, etc..

    http://goo.gl/f0Tv1p

    #234054

    Hey!

    Have you checked in another computer? i just tried reproducing the issue on FF 27 (Mac) with no success, the product linking is working as expected.

    Regards,
    Josue

    #234067

    I just checked the Replete demo site awhile ago, and the same issue occurs there as well.

    It’s been checked on multiple computers. On some it works, on others you have to double click on the product thumbnail instead of a single click. On this machine I’m using Firefox 27.0.1. and it doesn’t seem to produce the bug in Chrome. Haven’t checked I.E.

    My client said it was working fine on his home computer, but doing what’s been reported here on his office computer. This is definitely a bug.

    Also, the nav buttons on the left and right of the homepage slider are missing in Firefox, but displaying correctly in Chrome.

    • This reply was modified 6 months, 1 week ago by  Daymon74.
    • This reply was modified 6 months, 1 week ago by  Daymon74.
    #234083

    I just noticed the sticky header menu is not working in Firefox either. And isn’t the social bar (on the right side of the page) supposed to be sticky too? It’s not working in Chrome, or Firefox. As mentioned above, the same problems occur here http://www.kriesi.at/themes/replete/ as well. Tested on multiple machines on completely different networks. It’s looking like something’s buggy with Firefox.

    #234300

    Hey!

    Thank you for using the theme. I hope you’re doing great.

    On what browser version and OS are you testing this with? I tested the site on Chrome and Firefox Windows 8 and I can go to the product details on a single click. The sticky header is not working on Chrome Windows 8 but works properly on Firefox.

    Cheers!
    Ismael

    #234321

    Hi,
    The theme is great… one of my favorites. I’m on Windows 8 as well (not 8.1).

    #235076

    Hey!

    It sounds like this is when going to the site through Windows 8′s dashboard and not through the desktop on a computer with a touchscreen. As far as I know Windows tells the browser that the user is on a touch device and treats hovers as clicks (like would be on a phone).

    Is this on a touchscreen running the browser from the tiles area rather than the traditional desktop?

    Regards,
    Devin

    #235087

    Hi. It’s using the traditional desktop browser. There’s no touch screen capability on this computer. On a side note… I’m suspecting jQuery as the culprit, but I wouldn’t know where to start looking.

    • This reply was modified 6 months, 1 week ago by  Daymon74.
    #236172

    Hey!

    I’m also unable to reproduce this issue with Firefox 27.0.1 and Win 8.1: http://www.screenr.com/H7UN . Maybe try to test the website with another PC. I also recommend to deactivate all browser extensions and to update Abundance, WooCommerce and WordPress to the latest versions. (Abundance 2.1 is the latest theme version). If this still doesn’t help try to deactivate all plugins except WooCommerce.
    Cheers!
    Peter

    #236291

    Hi Dude,
    I’ve already gone through the steps you mentioned as a first off. I’m also using Replete. It’s been tried, and duplicated on different machines here. I’m pretty sure all of the problems above are somehow related to Firefox and jQuery, and I think Devin was closest to getting to the core issue. I’m running Windows 8 (not 8.1), so it’s very possible it could be the combo of Win 8, Firefox 27, and jQuery, but since I didn’t create the theme I wouldn’t know where to look within the theme files to debug.

    #236989

    Its the first I’ve heard of anyone having this kind of issue so it is singularly odd. Without being able to reproduce there isn’t much in the way of debugging that we can do unfortunately.

    As for being related to jquery, that seems unlikely. The hover effect and click events are pure css and there isn’t any javascript effects being applied to the shop items. Still possible but there would need to be something else involved outside the theme as far as I know.

    #237044

    Aren’t the shop products (not single) ajax? That’s not pure CSS. I understand you’re not able to reproduce the issue, but both the client I set this up for, and myself experience the same issue.

    Also, I would think the fact that in Firefox 27 the main menu is not sticky, and the left / right nav arrows in the main slider are missing, plus the issue with having to click twice on product thumbnail images (not the product buttons) would narrow down the culprit for you. These are all Firefox specific, so there is something they have in common somewhere. What could it be?

    #237532

    Hi!

    I tagged this thread for Kriesi. Maybe he knows what might cause this issue(s).

    Best regards,
    Peter

    #237772

    Thank you. Much appreciated!

    #239028

    Hi!

    I am also having troubles reproducing the issue but will set aside some debugging time after the next update round and see if I can find out what could possibly cause this…

    Cheers!
    Kriesi

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Have to Double Click Product Thumbnails’ is closed to new replies.