Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #281220

    Every time I try and upload my logo or an image I get the following:

    Unable to create directory wp-content/uploads/2013/04. Is its parent directory writable by the server?

    I tried to manually create the folder, but that didn’t work either as it changes it back to wp-content/uploads/

    So …HELP I guess.

    Charl

    #281276

    Hey charl1288xixsmile!

    Please make sure that wp-content>uploads folder has correct permissions ( 755 )

    Regards,
    Yigit

    #282364

    Thanks Yigit

    I will look into it.

    regards Charl

    #282378

    Hi Charl!

    Please let us know so we can mark this thread or assist you further :) We will be waiting to hear from you

    Cheers!
    Yigit

    #282401

    Hi Yigit

    So first I set settings > media ‘Organize my uploads into month- and year-based folders’ to inactive

    Then I checked wp-content > uploads file permissions and it was already set to 755

    I tried to upload my logo and it didn’t work, I got the following message
    ‘The uploaded file could not be moved to wp-content/uploads’

    So I followed the following instructions: http://www.wpbeginner.com/wp-tutorials/how-to-fix-image-upload-issue-in-wordpress/

    …and I still can’t upload my logo or any other image over the Media uploader?

    Even when I activate ‘Organize my uploads into month- and year-based folders’ in settings > media I can’t upload images.

    So I have no idea what to do now?

    regards Charl

    #282416

    Hey!

    Do you mind creating a temporary admin login and posting it here privately so we can look into it?

    Cheers!
    Yigit

    #282451
    This reply has been marked as private.
    #282824

    Hey Char,

    I activated the default WP theme and tried uploading a file and the error occurred, so the problem is not related to the theme but to the server. I suggest contacting your hosting support regarding this issue, there is little we can do from our end.

    Cheers!
    Josue

    #282909

    Hi Josue

    Thanks for your feedback and time.

    I spoke to my provider and they are keen to help but also asked if you have any idea what the problem is. Also if you have a list of requirements relating to hosting your template?

    Without that they say they can’t start looking into the problem.

    many thanks
    Charl

    #283175

    Hey!

    You can try to change the folder permission to 777 – maybe 755 is not enough in your case. We have no list of minimum requirements because it depends on the wordpress plugins, etc. you want to use but we recommend php5.4, 30 seconds (or more) php execution time and 128 megabyte allocated php memory. PHP5.5 should also work but because some plugins are still not compatible with the latest php version 5.4 is probably the better choice.

    Best regards,
    Peter

    #283466

    Hi Dude

    Thanks you so much for the help and your time. I will try 777 and if that doesn’t work I will change providers, seems like the simplest option.

    many thanks
    Charl

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘having problems uploading images’ is closed to new replies.