Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #8471

    So i’m trying to set up the ability for my google+ Picture/page to show up on a google search when you search for my site and articles through google. Ive been trying to work it out but need some help. (I think) I need to link my author page to google+ (and obviously other steps). However, when you click on the author it redirects you to a page showing all the post by me.

    I would like to change the author page to be redirected to an about page. http://iphoneinformant.com/about

    So i know i should insert some code in single.php but i don’t know what/where to put it.

    Thanks for the help.

    my site: http://iphoneinformant.com

    the current author page: http://www.iphoneinformant.com/author/ipho0947/

    #61477

    Well, Dude – sign me up!

    Im stuck at that same issue here. And a Google released their Google+ Autorship program, i`m sure such topics will no starts to appear ofter on that SupportBlog.

    Issue in short terms:

    We havee a G+ account. And our website. We must create a 2-way links…. everything is pretty easy here.

    Aside from the fact, that Google (how? why?) “detects” that the site is running on a WordPress engine.

    And, since the Google is an uber smart folk – the crawler tryes to set a link “triangle”

    1) G+ profile

    2) our website content (postpagearticle)

    3) and the “Author page” on the wordpress.

    And here comes the problems, because half of the Kriesi theme just demolished the “author Bio Page”.

    ======================

    Here you can check the real examle (my website):

    1) We go onto http://www.google.com/webmasters/tools/richsnippets

    Its an easy tool to “check” the way of Autorship worksdont works.

    There if we type:

    a) (index page of website) http://imba-shopping.com/ – we will see: Verified: Authorship markup is verified for this page.

    b) (pagesection link) http://imba-shopping.com/shopping-columns-view/ – SAME HERE. we will see: Verified: Authorship markup is verified for this page.

    (Those two pages actualy receive the G+ “verification” just because i`ve inserted the back-link onto my G+ account in one of the Widgets. And seems like the Google “see” that back link.

    But here goes the trycky part: Verification of POSTS…..

    If you go on http://www.google.com/webmasters/tools/richsnippets agai, and test this post link….: http://imba-shopping.com/31-tokyoflash-watches/

    You wont see a magical “AUTORSHIP VERIVIED” line. Because somehow, when Google check nor a oage, but “post” in wordpress, its automatically link it with a “author profile” inside our wordpress…..

    but since there is no such page…. Google cant find that page = cant find a Snippet backLInk = cant verify the Autorship.

    ==================

    I believe, thats the most straightforward way of solving this is just to modify onto “WHERE” the Author page will be linked.

    I mean, where must be a way to modify the ahref link to where crawler will be sended when it will check “autor” page.

    And of the most super way is to link it right back to the G+ account.

    Example: We read our post, and at the end of it there is a line: Comments, tags, category, author XXXX”

    If XXXX will lead to G+ = that will solve oll the issues for everyone.

    ============

    See, i`ve got the solution for you)) so, just give us the php code back Dude ))))

    PS: I have that issue on Corona theme, buts thats isnt really matters.

    #61478

    UPDATE:

    Issue solved.

    Just create 2 different widgets linking the G+ account. 2 links, but with different “REL” parameters.

    Here is how it performed onto my website.

    For example that post is now verified by Google: http://imba-shopping.com/30-spyder-taobao/

    There is TWO G+ links on that page.

    One (on left column) (its a vidget with this HTML:

    – a rel=”author” href=”https://plus.google.com/116164036679087348270/” –

    And there is another FOOTER WIDGET on the end of the website which have “REL=ME” html markup:

    – a rel=”me” href=”https://plus.google.com/116164036679087348270/” –

    ==========================

    check:

    go here: http://www.google.com/webmasters/tools/richsnippets

    type that: http://imba-shopping.com/30-spyder-taobao/

    see this: author

    linked author profile = http://imba-shopping.com/author/imbaroot/

    Error: Author profile page redirects to another URL

    redirect url = http://imba-shopping.com/

    google profile = http://profiles.google.com/116164036679087348270/about

    author name = Daniel Pouzankov

    Verified: Authorship markup is verified for this page.

    ====================================

    BANG! :-)

    PS: Im sure that soon Google with put a great pressure against CopyPasters and other content theft.

    #61479

    didnt work for me =

    #61480

    ok got it working, here is what i did for any one who also might want to do this. keep in mind what i did is just a shit load of trial and error so there might be extra stuff im telling you to add. make two buttons from here http://www.google.com/webmasters/profilebutton/ one with rel author and one with rel me. put them in differend widgets in the footer. i also did what imba said too so maybe its a combination of the two? i duno, im just happy i got it working now.

    #61481

    Thats the point. You need one back-link with REL=ME parameter and one more back-link to G+ account with REL=AUTTHOR parameter.

    Why is it so ? I have no F clue.

    For an ordinarry website, you need only one back-lcink. So its something about wordpress engine. Nevermind, its solved, its working, so its good.

    BTW, iphoneinfor, when you got all you back-links working, dont forget to apply you accountwebsite here for a final verification (dont know what is does so far): https://spreadsheets.google.com/spreadsheet/viewform?formkey=dHdCLVRwcTlvOWFKQXhNbEgtbE10QVE6MQ&ndplr=1

Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘Help Adding Author Page’ is closed to new replies.