Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #2021

    Well it turns out I am getting javascript errors from my “mailing list form” script that is running in a widget in the sidebar. It seems to cause errors with javascript on any page I place it on. Here is a link to a “toggle” example demo page.

    http://christopherferreira.com/stage/a-little-about-you/advanced-shortcodes/

    I keep getting the same error in line 14..

    I actually kinda have to use the mailing list form they provide me with as it is part of a larger service I use.. Any ideas how I can get around this problem?

    Thanks!

    #36347

    Update:

    The error comes from custom.js and reads:

    TypeError: Result of expression ‘portfolioSorter.kriesi_portfolio_sort’ [undefined] is not a function.

    the Java script on the widget is very short and simple, I don’t see where there can be a conflict.. Any ideas?

    #36348

    I think the javascript error is caused by a corrupt body tag. If you look at your source code you’ll see that

    <body>

    isn’t closed. Instead the code is:

    <body id='top' class="page page-id-50 page-child parent-pageid-37 page-template page-template-default"

    Please correct this error (in header.php) and everything should work. Please append a “>” to <body…..

    #36349

    Hey Dude,

    I couldn’t find the exact code you gave in the Header.php.

    I did find this similar code with open body tag:

    #####################################################################

    # check which page and apply classes to body

    ######################################################################

    $k_option = ”;

    ?>

    <body id=’top’ <?php body_class($k_option);?>

    If I close this body tag, the main NAV menu’s go vertical! – and the toggles still don’t work. Hmm

    Is there anyplace else I should look for the code you mentioned besides header.php?

    Thanks for the help.

    Also, the site you worked on with the different photo backgrounds on each page is awesome!

    #36350

    1)Can you try to replace:

    <body id='top' <?php body_class($k_option['custom']['bodyclass']);?>

    with

    <body id='top' <?php body_class($k_option['custom']['bodyclass']);?> >

    in header.php

    2) Glad that you like my website :D – I invested some time in modifications and styling.

    #36351

    Hey Dude,

    I did that, and I don’t see any effect. The toggles and slideshows on the page still don’t work. Anything else that could be causing it?

    Thanks.

    The photos in your website are great as well. Are they your photos?

    #36352

    I got it sorted. I found a workaround to using the widget that I think was causing the javascript errors..

    #36353

    No – I downloaded them from various locations – they are all free for personal (and commercial) usage. Glad that you sorted it out. I had a look at the javascript but couldn’t find the code which caused conflict. Maybe a global variable caused it….

    #36354

    Thanks for checking. It all seems good now.

    Cheers!

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Help with Javascript error..’ is closed to new replies.