Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #21982

    Hi there,

    if I do a mouse-over over a picture (in my blog). The ALT-text – in the yellow box – begins always with

    “Permanent Link: title”, for example the blog-entry “Breakfast in America” ALT-text shows: “Permanent Link: Breakfast in America””

    Please check here:

    http://belichtungskorrektur.de/blog/

    The source code:

    <a class=’external-link preview_image_full’ href=’http://belichtungskorrektur.de/breakfast-in-america/’

    rel=’bookmark’ title=’Permanent Link: Breakfast in America’><img width=”430″ height=”287″

    src=”http://belichtungskorrektur.de/wp-content/uploads/2013/04/Surfbrett-Kreidetafel-amerikanisches-Früh

    stück-430×287.jpg” class=”attachment-blog wp-post-image” alt=”Blonde Surferin präsentiert amerikanisches

    Frühstück auf Surfbrett als Kreidetafel” />

    How can I disable/hide the text “Permanent Link:” in the source code?

    Do i need to modify some php-files? If so, a detailed description would be great and very helpful to me.

    Many thanks in advance.

    #113776

    Yes, open up wp-contentthemesflashlightincludesloop-index.php and replace following code:

    <a href="<?php echo get_permalink() ?>" rel="bookmark" title="<?php _e('Permanent Link:','avia_framework')?> <?php the_title(); ?>"><?php the_title(); ?></a>

    with

    <a href="<?php echo get_permalink() ?>" rel="bookmark"><?php the_title(); ?></a>

    #113777

    Hi Dude,

    thanks for the hint, I will try this. What about the line

    <a class='external-link $class' href='".get_permalink()."' rel='bookmark' title='".__('Permanent Link:','avia_framework')." ".get_the_title()."'>".$image."</a>

    in the loop-index.php?

    Regards

    #113778

    @Dude

    The problem isn’t fixed – I’ve done your recommended code-replace, and deleted the cache.

    But I’ve found out, that NOT the ALT-text is displayed in the small yellow box (at mouse-over) – it is the TITLE-text!

    In the blog there is still

    “Permanent Link: Example Title-Text”

    in every small yellow-box (mouse-over over the the images) visible.

    Any other ideas?

    Regards

    #113779

    In this case I’d recommend to use jquery to remove the title attribute if the user hovers the cursor over the link. Open up wp-content/themes/flashlight/avia.js and at the very bottom of the file insert:

    jQuery(document).ready(function(){
    jQuery("a").hover(function(){
    var title = jQuery(this).attr("title");
    jQuery(this).attr("tmp_title", title);
    jQuery(this).attr("title","");
    },
    function() { // Fired when we leave the element
    var title = jQuery(this).attr("tmp_title");
    jQuery(this).attr("title", title);
    });
    });

    #113780

    @Dude,

    thanks a lot for your recommendation, I will try today evening …

    Regards

    #113781

    @Dude,,

    i’ve done the modification on the avia.js file – but it didn’t solved the problem !

    regards

    Michael

    #113782

    Hi!

    Please try to clear your browser cache – I just tested your website and it works fine for me. http://www.screenr.com/Cx37

    Regards,

    Peter

    #113783

    Hi – I am trying to do the same thing by deleting the yellow title on the images. I tried your solution and it isn’t working? I am on the Corona theme. Any ideas would be much appreciated!

    Here’s the page – http://50.87.167.161/~mcdouga4/single-family/

    Thank you!

    #113784

    Hi,

    I tested Dude’s code on Corona and it works. You will not see the title attribute on hover. Please remove browser cache the reload then page.

    Regards,

    Ismael

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘How disable/hide the text "Permanent Link:" in the ALT-text in images?’ is closed to new replies.