Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #25403

    Hi,

    1.

    I use Enfold theme, and WP mail SMTP plugin. I would like to change the kontakt form email sender name from the email adress to a specific name. In the settings of WP mail SMTP plugin I defined this sender name, but the emails arrive with the sender name: (Email address hidden if logged out) , not with the defined name in the plugin. When I send a mail with the kontakt form so, that I leave blank the box below:

    Your email addressEnter the Email address where mails should be delivered to. (Default: (Email address hidden if logged out) ‘)

    than the email sender will missing from the arriving emails.

    Can you suggest any solution for changing the email sender name?

    2.

    I was testing the kontakt form email sendig on my site, and experienced, when I want to send an email from the same page again, only after refreshing tha page, it does not work. When I navigate on another page on the site after sending the mail, and back again on previous page, and send email again, than it works.

    I think it is not a normal working of the kontakt form. When I can see the form, I must have beeen able to send email from it.

    What do you think about it?

    Thanks: Agnes

    #126840

    Hi,

    an additional info to email sender name problem: in gmail the sender name is only: info, not the email address, or the name, I defined in the WP mail SMTP plugin. It is very bad, that the client doesnt see, who is the email coming from.

    thanks: Agnes

    #126841

    Hi Agnes,

    To change the from field please open up /framework/php/class-form-generator and find line 450 , 453, 457

    Line 453 which looks like

    if(!empty($default_from['host'])) $from = "no-reply@".$default_from['host'];

    you can change to

    if(!empty($default_from['host'])) $from = " (Email address hidden if logged out) ";

    and 457 you can change from

    $from = $_POST[$this->autoresponder[0]];

    to

    $from = " (Email address hidden if logged out) ";

    Though I am not sure which one you would need . I would change all 3 and do a test and do a second test without 453 changed , to see that it performs how you need it to.

    Thanks,

    Nick

    #126842

    Hi Nick,

    thank you, but it not works so.

    You have not given me the code line: 450

    Test 1. ) I have made: I changed the lines 453 and 457, like you have written. Result: The Autoresponder arrived not to the client email, but to us back (to our email: (Email address hidden if logged out) ).

    Test. 2.) I have changed line 457. Result: the same, as by Test 1. )

    Test. 3.) I have changed line 453. to: if(!empty($default_from)) $from = “Míveskönyv Könyvmanufaktúra”;

    Result: The Autoresponder arrives to the client email again, like original, it is OK, but the from name is: In Outlook ” (Email address hidden if logged out) ” (our default email), in gmail: only the first part of the email address: “info”.

    I would like the from name to be in Autoresponders “Míveskönyv Könyvmanufaktúra”, and not our email address, or a part of the email address! I see my arriving emails from others, and their from name is the company name, not email address.

    Anyway, you havent answered my second question yet.:

    2.

    I was testing the kontakt form email sendig on my site, and experienced, when I want to send an email from the same page again, only after refreshing tha page, it does not work. When I navigate on another page on the site after sending the mail, and back again on previous page, and send email again, than it works.

    I think it is not a normal working of the kontakt form. When I can see the form, I must have beeen able to send email from it.

    What do you think about it?

    Best Regards:

    Agnes

    #126843

    Hi,

    Thanks for doing the tests!

    1.

    Do this instead. Find lines 549 and 554 in the same file, they both should start the same … $header .=

    and change them to

    $header .= 'From: Míveskönyv Könyvmanufaktúra < (Email address hidden if logged out) >' . "rn";

    2. I tested it a bunch of times on your site now using (Email address hidden if logged out) … and they all went through when I refreshed the page. I used Chrome browser, what are you using? What happens when you do it a second time – no form, error message..etc?

    Thanks

    Nick

    #126844

    Hi,

    thanks,

    1.

    The new code lines works. Only one problem remained: In outlook the from name: Míveskönyv Könyvmanufaktúra looks like this: MÖveskönyv Könyvmanufaktúra. It is because of the hungarian letter characters with accents. But with the former theme: Abundance it was not like this. In gmail the hungarian characters are OK. Have you any idea, what can cause this?

    2.

    I have seen 3 of your tests coming from miveskonyv.hu kontakt form.

    I use Firefox, but I tried Chrome also. In both the issue is existing. When I try to send a message second time after refreshing the page, the form desappears after sending, but no success message like: Your message was sent successfull, is displaing. No error message either.

    Thanks, Best Regards:

    Agnes

    #126845

    Hi,

    Your blog. You are using UTF8 character encoding in wp-config.php?

    Please try this instead of the line from my previous post

    $header .= 'From: ' .htmlspecialchars("Míveskönyv Könyvmanufaktúra"). ' < (Email address hidden if logged out) > rn';

    We’ll get to the bottom of this. Since the theme is used in Greek language and works , I think we will get it working in Magyar.

    Lets finish with this first and then deal with the contact form reload issue, I am still looking at it.

    Thanks,

    Nick

    #126846

    Hi,

    I changed the given code line.

    It is very strange for me: when I send the kontakt form test message from my gmail address, then the autoresponder emails from name in gmail is korrekt: every hungarian charakter is displayed well.

    But in Outlook in the from name hungarian charakters are still bad.

    Your other question: You are using UTF8 character encoding in wp-config.php?

    I found these lines in the wp-config.php:

    /** Az adatbázis karakter kódolása */

    define(‘DB_CHARSET’, ‘utf8′);

    So I think yes.

    Regards:

    Agnes

    #126847

    Hi,

    I tried this a number of times from a live test site using that name, and on google and yahoo , everything comes out fine. I don’t have Outlook to test it.

    Please insert this in place of the one line i pasted in my previous reply (in both locations lines 549 and 554)

    $ttr = "";
    $ttr = utf8_encode("Míveskönyv Könyvmanufaktúra");
    $header .= 'From: ' . htmlspecialchars($ttr) . ' < (Email address hidden if logged out) > rn';

    Thanks,

    NIck

    #126848

    Hi,

    I placed the code lines you given in the place of both locations. Nothing changed.

    Regards:

    Agnes

    #126849

    Hi,

    I installed Outlook 2010 and sent an email. Using my last instructions.

    Please take a look : http://i.imgur.com/DE67EIS.png

    Here is how it looks in Gmail. http://www.clipular.com/c?9133179=32xoCQzQl_Qjo5vLZACwnGHBAWY&f=.png

    I am not an expert on Outlook settings so am not sure what yours are. Perhaps you can test it with a different outlook on a different computer?

    Thanks,

    Nick

    #126850

    Hi,

    thanks, it is good news, that it works in Outlook. Maybe on Macintosh version is something different.

    Bestr Regards:

    Agnes

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘How to change email sender name’ is closed to new replies.