Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #170201

    Hi —

    After setting up the pages, I didn’t realize this theme’s permalinks defaulted to /?p=123.
    What can I do to override the permalink set-up (want to customize)?
    I’m new to WP and have done minimal edits to code. Are there a few simple steps to correct this without having to rebuilt the site?

    Thanks,
    Doreen

    #170207

    Hello Doreen!

    Go to Settings > Permalinks, select the structure you want and Save.

    If you need more information, here’s a post that covers it thoroughly.

    Regards,
    Josue

    #170428

    Hi Josue,

    I did just that and the pages were not longer linked — got an error message:

    The requested URL /about-us/ was not found on this server.

    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    Apache/2.2.24 (Unix) mod_ssl/2.2.24 OpenSSL/0.9.8e-fips-rhel5 DAV/2 mod_mono/2.6.3 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 mod_jk/1.2.35 PHP/5.3.24 mod_perl/2.0.6 Perl/v5.8.8 Server at echo-bravo.com Port 80

    — Doreen

    #171337

    Hi Doreen,

    The theme doesn’t have anything to do with the permalink settings actually. You can customize them as Josue mentioned in the WordPress options. After that however any links that were previously pointing to the old link will need to be changed unless they were relative links from WordPress.

    If the post name option isn’t working you can try the troubleshooting tips in the codex here: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Best regards,
    Devin

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘How to change permalinks after pages have been created’ is closed to new replies.