Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #18161

    I’m struggling to increase the size on the product detail page:

    In the WooCommerce Catalog Settings I set the “Single Product Image” size to 660x440px .

    In the WP Settings/Media I set the “shop_catalog size” and the “shop_catalog size” both to 660x440px.

    In the product page I set the thumbnail to “full-size” (1024x680px).

    The image size on the product detail page does not change at all.

    Can anybody help me on this?

    #98449

    Hi,

    You can add this on your custom.css

    .single-product .content .box {
    width: 700px;
    }

    Adjust the width of the box.

    Regards,

    Ismael

    #98450

    thanks, Ismael

    unfortunately I see no effect … (even when I set it to 900px)

    any other suggestion?

    is there maybe some setting that prevents all these efforts from being effective?

    #98451

    Hi bruwa,

    Can you post a link to your site? so we can check it.

    Regards,

    Ismael

    #98452

    my test site is at http://www.wp.fotowalther.ch/

    #98453

    Hi bruwa,

    I believe Ismael misunderstood. The above css changes the page width and not the image.

    The image size is generated by the size set by the theme. The easiest way to change it is to use something like http://wordpress.org/extend/plugins/simple-image-sizes/

    After you have changed the image size, make sure to regenerate the thumbnails so that the new size is generated as an image.

    Also make sure to add the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.single-product .entry-content {
    width: auto;
    }

    This is a fix I noticed needs to be done but doesn’t seem to have made it into the last theme update.

    Regards,

    Devin

    #98454

    Hi Devin

    - I changed image sizes with the simple-image-sizes plugin, then updated and saved.

    – I changed image sizes in the WooCommerce Catalog Settings and saved.

    – I opened every product page: thumbnail is set to “full-size” (1024x680px), I regenerated the thumbnail. Saved and updated the page

    – I added your suggested code to the Quick CSS:

    Unfortunately there is still no change of the image size in the Product Detail page…

    Although the image size of catalog and product detail are both set to 900×600, the images on the product detail page are much smaller than those on the category page!

    I also regenerated the thumbnails with the “simple-image-size” plugin (batch mode) – no change.

    I also discover now that the product price does not show on this page (it shows on the category page)

    Regards,

    Bruno

    **************

    example Product Detail page: http://www.wp.fotowalther.ch/?product=us-8073

    #98455

    I inspected the product detail image with Firebug.

    If my understanding is correct, it seems that a downsized image of 200x140px is used.

    I wonder where this process is controlled and why we were unable to override it:

    <div class=”avia_embed_image avia_3_column_gallery first”> …..

    ….wp-content/uploads/1010_D3A_8052-200×140.jpg” />

    (there is probably a container where the image needs to fit in, so I assume I would first need to adjust the container size?)

    #98456

    Hi Bruno,

    I’m really not sure whats going on because in my test installation it doesn’t use that small of an image. It adjusts to the page width in the slideshow area.

    Have you tried changing the display setting for the image gallery to something else?

    Also try disabling all active plugins except for WooCommerce and then creating a new sample product and testing the different gallery display methods for that one single product.

    Regards,

    Devin

    #98457

    Hi Devin

    Thanks.

    I will try this and will keep you posted.

    Regards,

    Bruno

    #98458

    Let us know how it goes.

    Regards,

    Devin

    #98459

    Devin,

    when I edit the product and change the gallery layout to

    “WordPress default …”, then I get an 80×80 thumbnail, even if I set the thumbnail size to 450×450 (and regenerated)

    - “Slideshow at the top …”. then the image fills the entire width of the page.

    ******************

    with the gallery layout set to “Slideshow at the top …”

    – I changed the size of the shop_single size in the media settings (from 900×600 to 450×450) and regenerated the thumbnail -> no change.

    – I changed the image options (one at a time) in the WooCommerce Catalog Settings[b/b] from 900×600 to 450×450 -> no change

    **************

    when I change the thumbnail size from 80×80 to 450×450 (media settings), save, and check the product image (edit product/upload) the option “thumbnail” still shows 80×80

    *************

    Finally I deactivated all plugins, except the WooCommerce, and created a new (single) product:

    http://www.wp.fotowalther.ch/?product=italy-2241

    with the new size settings as mentioned above unchanged -> no effect

    ************

    Summary:

    The size of the image on the product detail page is always smaller than on the category page (unless I set the gallery option to “Slideshow at the top…”)

    I’m sure I did not forget to regenerate and save after any change.

    Does any other setting come to your mind which might affect this image size?

    The plugin “Simple Image Size” allows (among others) to set the size of 3 shop image types (thumbnail, catalog, single) – the same image types can be adjusted in the WooCommerce Catalog settings. Changes in the “media settings” are not reflected in the “WC catalog settings. How do the media settings and WooCommerce interact? Who takes priority?).

    Please remember: the image size settings had no effect on the product image size even when the plugin was disabled.

    I have the latest theme version installed (purchased on November 23).

    Thanks,

    Bruno

    #98460

    Hi,

    Please remove the image and reupload it. You will see the correct size. For some reason the regenerate plugin fails to work on some websites due to low memory allocation by your host in the php.ini file.

    I have fixed this problem dozens of times. The only way to do it. Is to (a) change the size of the image (b) upload image again to test how it looks.

    *When you upload the image , make sure that you select with radio buttons during the upload the image size that you want.*

    If you want, email me an admin login/pw to wordpress to usjahm (aaattt) gmail (dddooottt) com so I can see if memory is the issue.

    Thanks,

    Nick

    #98461

    Hi Nick,

    I already had contacted the host and he had set the memory for PHP to 256 MB.

    Despite this, the System Status still showed a WP Memory of 32 MB.

    The host’s support guy the discovered that the file wp-includes/default-constants.php

    included the line “define(‘WP_MEMORY_LIMIT’, ’32M’);”, apparently overriding the 64 MB setting in the config.php

    After setting this to 256 MB the System Status also reflects this change.

    So, having this out of the way I created a new category (Memory-Test) and created a new product (MT 4417) in this category.

    When I uploaded the image I selected the image size “Large (1024×685)”, saved and published it.

    Unfortunately the problem remains: the image on the product detail page is smaller than the one on the category page.

    http://www.wp.fotowalther.ch/?product=mt-4417

    I haven’t touched any settings.

    I will be happy to send you an admin login so you can check.

    Regards,

    Bruno

    #98462

    Hi,

    I looked at your site as I wrote in the email to you . To reiterate:

    Something is very very badly screwed up with this theme. Have you edited the logic or code at all to customize it? Because parts are missing, Bottom halves of multiple pages are missing Products are not being listen in categories,

    I would delete the whole thing including wordpress and start fresh. Delete via FTP so this way all the database data will remain intact. I am ading products and they aren’t even showing up. Kill it quietly via ftp and when theme, delete everything except the wp-content folder, and the wp-config.php file in the root. then inside wp-content delete all the plugin and delete the theme. And then upload new ones via ftp and only then go to the admin page.

    Thanks,

    Nick

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘How to increase the image size in the product detail page?’ is closed to new replies.