Viewing 26 posts - 1 through 26 (of 26 total)
  • Author
    Posts
  • #195432

    Hello,
    i tried to upload 2 iconfont via manager and i get this error:
    Couldn’t add the font.
    The script returned the following error:

    Fatal error: Class ‘ZipArchive’ not found in /web/htdocs/www.studiovitruvio.it/home/v3/wp-content/themes/enfold/config-templatebuilder/avia-template-builder/php/font-manager.class.php on line 103

    I already tried to deactivate all the plugins and upload the enfold theme via FTP but still got the same message.
    Please help.

    #195985

    Hey bitinteractive!

    What version of PHP does your server have?

    Regards,
    Josue

    #196035

    Hello,
    version 5.3.27

    #196585

    Hey!

    ZipArchive is a standard php function: http://www.php.net/manual/en/class.ziparchive.php
    If your server returns an error like “Class ‘ZipArchive’ not found” please contact your hoster and ask the server administrator to activate the ZipArchive class/feature for you. Maybe they need to update the php version or change the php.ini config file for you.

    Regards,
    Peter

    #242138

    I get the following error when uploading a font via iconfont manager…

    Couldn’t add the font.
    The script returned the following error:

    Fatal error: Call to a member function attributes() on a non-object in /……./themes/enfold/enfold/config-templatebuilder/avia-template-builder/php/font-manager.class.php on line 179

    I am using PHP 5.3

    • This reply was modified 3 weeks, 3 days ago by  rseybold.
    #242334
    This reply has been marked as private.
    #242472

    Hi!

    Please ask your host if the php option Ziparchive is enabled. Switch to a default theme then switch back to Enfold, try to upload the fonts again.

    Best regards,
    Ismael

    #242530

    Hi Ismael,

    ZIP is enabled, switching leads to same error.

    phpinfo says:

    zip

    Zip enabled
    Extension Version $Id: bdd35a2ede0347a3df239de1e7dc5d7e588f00c3 $
    Zip version 1.11.0
    Libzip version 0.10.1

    #242531
    This reply has been marked as private.
    #242535
    This reply has been marked as private.
    #242544
    This reply has been marked as private.
    #243401

    Hi Ismael,

    I checked with my host and our php option Ziparchive is enabled, I am still getting the error code when I try to upload icons…

    #243597

    Hi bitinteractive,

    I have the same problem, as I get the fatal error message in line 179 of the font manager class of Enfold, whenever I try to upload fontello icons.

    This will save me of all the fixes you’ve tried so far.

    Please let me know if you are able to get a final fix, and so will I.

    Regards

    #244085

    I also get this error…..all the same replies. I also have ZipArchive installed….If its broke just say so… And let us know on a estimated time for a fix.

    #244087

    I’ve just just checked with my host and they’ve said ZipArchive is a default setting in their servers.

    #244327

    Hi everyone!

    As always, thank you for using the theme!

    Unfortunately, we’re not entirely certain of the cause of the issue so if you have fixed the problem on your end by now, please kindly share it. We’re very sorry that you’re having this issue. If you don’t mind, we will be needing your login credentials for wordpress and FTP. Set it as a private reply. We will try to debug the errors on your end.

    A lot users are having the same issue and it might have something to do with server configuration. We have reported the issue to Kriesi.

    Cheers!
    Ismael

    #244462
    This reply has been marked as private.
    #245495
    This reply has been marked as private.
    #246895

    Hi!

    As always, thank you for using the support forum.

    Thank you for the login details. If you don’t mind, please post the the topic on a separate thread. Post the login details for the wordpress dashboard and FTP. Set it as a private reply.

    Regards,
    Ismael

    #251375

    Hi!

    I am still investigation the problem. would you mind posting your wordpress login details AND FTP details in a private reply so I can modify the necessary php files directly?

    Once I found a solution I will update the theme accordingly :)

    Cheers!
    Kriesi

    #251467
    This reply has been marked as private.
    #252081

    Hey @rseybold !

    Thanks for that. Mind adding FTP credentials as well? In order to fix the problem I will need to do some trial/error testing with a few lines of code, something which is not really possible without FTP access to the theme folder :)

    Cheers!
    Kriesi

    #252098
    This reply has been marked as private.
    #252108

    Thanks!

    Icon uploading should work fine for you now ;)
    We will include the fix in the next update (version 2.7)

    #252223
    This reply has been marked as private.
    #252675

    Hi!

    We changed the config-templatebuilder/avia-template-builder/php/font-manager.class.php file.
    Version 2.7 will include the fix as well ;)

    Best regards,
    Kriesi

Viewing 26 posts - 1 through 26 (of 26 total)

The topic ‘Iconfont Manager upload problem’ is closed to new replies.