Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
    Posts
  • #16800

    Hi all, coherence them working well in all other browsers, just a couple of minor issues in IE 8.

    website: http://www.moo.com.au

    1. favicon not appearing – default red star appears instead (affects whole site)

    2. portfolio entry thumbnails are not changing from grey to colour on mouse hover (affects whole site)

    3. grey box isn’t appearing behind caption on images (e.g. http://www.moo.com.au/portfolio-item/branding-2/)

    4. image not appearing in portfolio post (http://www.moo.com.au/portfolio-item/ipar-marketing-services/)

    Above issues all appear correctly in safari and firefox.

    Any ideas on how to fix this?

    Cheers,

    Marty.

    #92900

    Hi Marty,

    For #1, its probably a cache issue but as long as the icon is set, it will be picked up by the browser. Beyond that there isn’t anything we can do.

    #2 – This is a limitation of IE8. It doesn’t support css3 transitions.

    #3 – There is something interfering with the themes ability to detect the browser version the user has. Try disabling all active plugins and then view the source of the page. The html class should say the browser and its version number as a class which is how version specific css is added in. Right now its just spitting out a question mark in place of a browser version.

    #4 – Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    .msie .avia-innerbox{ display: block;}

    I’ve not seen the issue with #3 before but that will definitely cause issues with specific browser fixes. If it isn’t a plugin issue, I’ll have to check with Kriesi to see what the specific function is that spits out the browser version or just dig around in the framework myself for it.

    Regards,

    Devin

    #92901

    Hi Devin,

    Thanks for your help!

    The additional CSS you provided worked a treat, so the image is now appearing in the post.

    The favicon and transitions we can live with, but the box behind the captions still isn’t working, even after i’ve disabled the plugins. I can’t seem to find what is wrong.

    Any other suggestions?

    Cheers,

    Marty.

    #92902

    In header.php.php replace following code:

    <link rel="stylesheet" href="<?php echo get_bloginfo('template_url'); ?>/css/custom.css" type="text/css" media="screen"/>

    with:

    <!--[if lt IE 9]>
    .caption_framed .slideshow_caption .slideshow_inner_caption {
    background: #000 !important;
    }
    <![endif]-->

    <link rel="stylesheet" href="<?php echo get_bloginfo('template_url'); ?>/css/custom.css" type="text/css" media="screen"/>

    This should fix the caption issue. Unfortunately IE8 and older browsers do not support transparent caption backgrounds without images because rgba is a css3 attribute. And eg the opacity filter would affect the text too.

Viewing 4 posts - 1 through 4 (of 4 total)

The topic ‘IE 8 Issues – favicon not appearing, portfolio issues’ is closed to new replies.