Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #24091

    Hello

    I’m using the Choices theme.

    I have several images on my pages that I’d like to click on and enlarge but I don’t want them to become a slideshow of all the other images on the page.

    Is there a way to just select the image and not have it part of a slideshow.

    Many thanks

    Pete

    #122280

    Hi,

    You can use the Upload/Insert Image button. Browse through your images then click “Insert into post”. You can select the thumbnail size and the alignment. It will look like this on your editor.

    <a href="http://localhost/kriesi/choices/wp-content/uploads/2012/04/1.jpg"><img class="alignnone size-full wp-image-313" title="1" src="http://localhost/kriesi/choices/wp-content/uploads/2012/04/1.jpg" alt="" width="1000" height="650" /></a>

    Regards,

    Ismael

    #122281

    Many thanks for the reply Ismael.

    I’m not having a problem inserting images into posts and pages.

    It’s when I’ve inserted them into a page and click and enlarge the image on the website, all the images on that page become a slideshow.

    I just want that one image to enlarge.

    Here’s a link to what I’m working on

    http://seecambo.boufon.co.uk/holidays/colours-of-cambodia/

    If you click on ‘Prices and Hotels’ then ‘Standard’ and then any image.

    Cheers

    Pete

    #122282

    Hi,

    Include the rel=”nolightbox” on the anchor tag.

    <a href="LINK" rel="nolightbox"><img src="YOUR IMAGE"></a>

    or use this

    <a href="LINK" rel="lightbox"><img src="YOUR IMAGE"></a>

    Regards,

    Ismael

    #122283

    Hi Ismael

    Many thanks for your reply – sorry it took awhile to get back to you.

    That didn’t work. Have cleared the cache and refreshed the browser and it still loads all the images on that page.

    Do you have any other ideas?

    Here’s the code that I used

    Angkor Home Hotel

    Cheers

    Pete

    #122284

    Doh!

    <!–Angkor Home Hotel –>

    #122285

    And I’ll try again!

    a href=”http://seecambo.boufon.co.uk/wp-content/uploads/2013/04/angkor-home-hotel-1-copy.jpg” rel=”noLightbox”>Angkor Home Hotel </a

    #122286

    Hey!

    It needs to be a class and not a rel attribute – use following code instead:

    <a href="http://seecambo.boufon.co.uk/wp-content/uploads/2013/04/angkor-home-hotel-1-copy.jpg" class="noLightbox">

    Best regards,

    Peter

    #122287

    Cheers Dude & Ismael for your help – it’s still not having it!

    Is there any other way of disabling it?

    Cheers

    Pete

    #122288

    Hi,

    Opps, my bad. Dude’s code should work. You can disable the lightbox entirely.

    Open js > avia.js, find this code:

    //activates the prettyphoto lightbox
    if(jQuery.fn.avia_activate_lightbox)
    jQuery(container).avia_activate_lightbox();

    Replace it with:

    //activates the prettyphoto lightbox
    //if(jQuery.fn.avia_activate_lightbox)
    //jQuery(container).avia_activate_lightbox();

    Cheers,

    Ismael

    #122289

    Thanks Ismael – that’s not really what I’m after – I still want the image to pop out but to just not link to every other image on the page.

    Thanks for both your help – I’ll see if there’s another way round this.

    Cheers

    Pete

    #122290

    In this case open up wp-contentthemeschoicesjsavia.js and replace:

    el.attr('rel','lightbox['+group+counter+']');

    with

    el.attr('rel','lightbox');

    However note that this will deactivate the lightbox slideshows for all images – not just gallery images.

    #122291

    I have to say I’ve become used to not relying on support for WP themes as it’s usually never there when you need it most.

    Thank you both for staying with me on this.

    That’s exactly what I was after.

    The only other issue is that ‘undefined’ appears where the numbers were before, is there a way of removing this?

    Huge thanks

    Pete

    #122292

    I used css to remove it.

    div.pp_default .pp_description {

    display: none !important;

    }

    Are there any likely issues from doing that you might be aware of?

    Cheers

    Pete

    #122293

    Hi,

    No, I think it is totally fine. Glad it is working now.

    Cheers,

    Ismael

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Images on page are creating an unwanted slideshow’ is closed to new replies.