Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #4949

    Hey guys,

    is there an easy way to import new fonts? I created a cufon font from the google web font Raleway, used cufon as font family and uploaded the file into the/themes/brightbox/framework/js/fonts/ folder. However, it does not appear in the drop-down menu in the Theme Options. What else do I have to do to include a new font?

    #48260

    Hey,

    you need to add the font to the option panel. Open up brightboxincludesadminregister-admin-options.php

    and search for following code:

    "subtype" => array(	'Arvo'=>'arvo',
    'Bevan'=>'bevan',
    'Cantarell'=>'cantarell',
    'Cardo'=>'cardo',
    'Droid Sans'=>'droidsans',
    'Inconsolata'=>'inconsolata',
    'Josefin All Characters'=>'josefine',
    'Josefin Common Characters'=>'josefine_small',
    'Kreon'=>'kreon',
    'Lobster'=>'lobster',
    'Molengo'=>'molengo',
    'Oswald'=>'oswald',
    'Reenie Beanie'=>'reeniebeanie__1.4', //number attached is a font size modifier for very small fonts ( * 1.4)
    'Tangerine'=>'tangerine__1.6',
    'Vollkorn'=>'vollkorn',
    'Yanone Kaffeesatz'=>'yanonekaffeesatz'
    ));

    Add your font to it. First text is the name of the font (how it will display in the user interface) and second text the name of the file without .font.js extension.

    #48261

    Hi Dude,

    I did the same (as described above) within Broadscope theme (font=Univers):

    Created it with cufon, copied the font (Univers_Com_45_Light_300.font.js) into wp-content/themes/broadscope/framework/js/fonts

    edited options.php within wp-content/themes/broadscope/includes/admin_option_pages.

    The entry is …

    ‘Tangerine’=>’tangerine’,

    ‘Univers’=>’Univers_Com_45_Light_300′,

    ‘Vollkorn’=>’vollkorn’,

    … but Univers doesn’t aopear in the dropdown menue …

    What else has to be done?

    Anything to “refresh”…?

    Thx & take care

    CArend

    #48262

    Hey,

    have a look at this thread: http://www.kriesi.at/support/topic/cufon-font

    If you’d like to import the new font you need to delete the Broadscope options table (wp_options > avia_options_broadscope_config ) in the sql databse.

    #48263

    Hi Dude,

    thx 4 ur response. “Renaming” didn’t work.

    The deletion of options table DID work,- and the (new) font name is visible.

    BUT it seems that (after choosing the new font) Broadscope takes the Font-setting “Select…” (which is the preset)

    and the desired font is not used within the theme.

    Even repeating all this with another font (and deleting SQL entry again) was not successful …

    The fonts were licensed @Adobe and cufon “conversion” went ok, too.

    May you’ve any other/additional ideas?

    Thx in advance & take care

    Christian

    #48264

    Can you post a link to your website – I’d like to check if the cufon file itself is corrupt or if the settings aren’t saved correct.

    #48265

    Yes-sure (website under construction): http://www.richmediafactory.com/nucycles/

    If you need any further information, screenshots or access pls. let me know ( (Email address hidden if logged out) ).

    Another page where the fonts “work” (with cufon) is http://www.richmediafactory.com/000rmfrelaunch2012/ (another skin though…).

    Thx- Christian

    #48266

    Ok – I see the problem. Your font file uses: “Univers Com 45 Light” as font family. Please use “cufon” instead. You can change the font family by using the cufon generator here: http://cufon.shoqolate.com/generate/ – upload your file and in the option field/text field “Use the following value as the font-family of the generated font (optional)” type in “cufon” (without “”). Afterwards place the file in the fonts folder :)

    #48267

    Hi Dude,

    that worked perfect – thanks a lot :)

    #48268

    Glad that I could help you :)

    #48269

    not working for me:

    I created the cufon.font.js and changed it to Komikax.font.js

    I have deleted all other font.js files except for Arvo.Font.js

    So in “register-admin-options.php” it looks like this now:

    fonts for your headings”,

    “id” => “font_heading”,

    “type” => “select”,

    “std” => “oswald”,

    “subtype” => array( ‘Komikax’=>’komikax’,

    ‘Arvo’=>’arvo’,

    ));

    I do see it as an option in Layout & Styling to select.

    #48270

    I found a thread that said just create the font.js file and change it to a font that is already made and it will work….

    #48271

    Hi,

    Instead of Komikax try using Komika Axis.

    Regards,

    Ismael

    #48272

    why do you suggest that version?

    #48273

    Hi,

    My guess is Komikax is not the name of the font but only the abbreviation of Komika Axis, the full name. So just as in :

    'Josefin All Characters'=>'josefine',

    you need to put first the full proper name, and then the file abbreviation.

    "subtype" => array(	'Komika Axis=>'komikax',

    Thanks,

    Nick

Viewing 15 posts - 1 through 15 (of 15 total)

The topic ‘Importing new Cufon fonts’ is closed to new replies.