Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #182603

    The infobox at the top, which is supposed to “show once and not more when dismissed” acts really weird since I launched my page, and/or perhaps since I activated W3 Total Cache. Before that, when I had it in maintenance mode, this wasn’t the case.

    In short, I don’t know how to describe it, really. It’s very unpredictable right now. It might not appear at all on the frontpage (if you clear browser cache etc.). But it might appear on for example regular pages, but most often not directly, but a few more seconds than usual after the page is done loading. It might also appear on some pages using “Template builder” based pages. But not all, or well – maybe not all the time.

    I sort of have a problem describing it, since I can’t find any logic to the trouble. I have a strong feeling it has something to do with W3TC, and perhaps “Cache Control policy” in particular. The behavior changed slightly it seemed, when I played around with the value(s). Anyone experienced the same thing, and what “Cache Control policy” do you use to make it work? Might be all wrong though.

    • This topic was modified 10 months, 2 weeks ago by  Skald.
    #183666

    Hey Skald!

    Yes, it’s a issue with W3TC. You can probably fix it by deactivating the page cache option which caches the html source code. If this option is activated W3TC will send the cached html file and won’t use the dynamic php code and this can break the infobox code at the top. The infobox uses a cookie to check if the user clicked the “close” button and if yes it will be hidden. If there’s no cookie the infobar will be displayed. However the page cache of W3TC breaks this cookie check and it will just send a static html source which shows the infobar or doesn’t show the infobar.

    You can try a plugin like: http://codecanyon.net/item/foobar-wordpress-notification-bars/411466 which should work with w3TC too.

    Best regards,
    Peter

    #183815

    Can’t seem to find any such settings under the Page Cache options. But, I disabled Page Cache completely, and I still get like “A-grade” and approx. 92% on Yslow and Pagespeed, and sites like Pingdom says my site is faster than 80% (cross contintent, that is). So I guess I can do without page cache, it’s more or less anyway what makes using cache a little problematic – going only for minify and browser cache now, and it seems to do a great job.

    And yeah, the infobox works perfectly alright now, like everything else I can think of. So great thanks, leading me into the direction of abandoning page cache will save me a lot of nonsense problems with other future sites. ;)

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Infobox lives its own life’ is closed to new replies.