Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #19500

    I have exactly same issue as is described in this (now closed) thread http://www.kriesi.at/support/topic/insert-shortcode-not-functioning-in-chromefirefox-only-ie10?replies=5#post-91558

    Propulsion Version 1.7 on WordPress 3.5

    Doesn’t work in Firefox 18, Chrome 24.

    Works in IE 9.

    Windows 7.

    I would like to take care of the issue. What steps are we going to take?

    Thanks a lot,

    Michal

    #103947

    Hi Michal,

    That user ended up switching to a different theme before we could help him.

    So far we are guessing its a server configuration but what that is, we aren’t sure. Another user who was having the same issue switched to a different server and the problem was resolved. A bit weird, but if you can give us any additional information about your server setup, file permissions etc we can go from there.

    Regards,

    Devin

    #103948

    Hi Devin,

    What kind of information exactly are you looking for? Here’s a PHP specification http://46.28.105.78/info.php

    What else can do you think you will need?

    Thanks,

    Michal

    #103949

    Any development?

    #103950

    Can you take a look at the file permissions for your wordpress installation (the chmod for wp-content and sub folders to start).

    If you have any plugins active, they should be disabled while trying to troubleshoot the shortcode issue as well.

    Regards,

    Devin

    #103951

    It looks like that wp-content and sub-directiories have 750 and files have 640.

    I tried with all plugins turned off with the same result.

    Thanks!

    Michal

    #103952

    Hi!

    Please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – I’ll look into it.

    Regards,

    Peter

    #103953

    Sent.

    Thank you,

    Michal

    #103954

    Hi,

    The problem is that the javascript files of the shortcode generator are not loaded properly. By default the urls to the javascript files look like:

    <script type="text/javascript" src="http://www.kriesi.at/themes/propulsion/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/column-control.js"></script>
    <script type="text/javascript" src="http://www.kriesi.at/themes/propulsion/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/tab-control.js"></script>
    <script type="text/javascript" src="http://www.kriesi.at/themes/propulsion/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/table-control.js"></script>
    <script type="text/javascript" src="http://www.kriesi.at/themes/propulsion/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/sidebar-tab-control.js"></script>

    <script type="text/javascript" src="http://www.kriesi.at/themes/propulsion/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/dialog.js"></script>

    However in your case something (maybe a plugin or your hoster (I’m not sure)) changes the default urls to:

    <script type="text/rocketscript" data-rocketsrc="http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/column-control.js"></script>
    <script type="text/rocketscript" data-rocketsrc="http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/tab-control.js"></script>
    <script type="text/rocketscript" data-rocketsrc="http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/table-control.js"></script>
    <script type="text/rocketscript" data-rocketsrc="http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/sidebar-tab-control.js"></script>

    <script type="text/rocketscript" data-rocketsrc="http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/js/dialog.js"></script>

    which will break the editor. You can view the source code of the shortcode editor here: http://slidevalue.com/wp-content/themes/propulsion/framework/php/avia_shortcodes/tinymce/dialog.php (you must be logged in to view the file)

    #103955

    I see. It’s caused by cloudflare.com (a security/CDN service) that has a feature called Rocket Loader that “automatically asynchronously load all JavaScript resources.” I turned it off and now it loads correctly.

    I’m sorry for taking your time — now I’ll try to get to their support. I suppose there’s nothing you can do, right? I’ll point their technicians here.

    Thanks a lot for your help,

    Michal

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Insert Shortcode not Working in Firefox or Chrome (only IE)’ is closed to new replies.