Tagged: , ,

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #10929

    Hi,

    I have a links page and I’m trying to add images to it and align them to right side.

    For some odd reason it just won’t work. Pictures continue to show on a left side of a page.

    The page is using default template page.

    Heres the example code:

    <a title="Sähkö- ja teleurakoitsijaliitto STUL ry" href="http://stul.fi/">Sähkö- ja teleurakoitsijaliitto STUL ry</a><a href="http://sahkovaronen.fi/wp-content/uploads/2012/01/2011-04-12_29428.jpg"><img title="kattovalaistus" src="http://sahkovaronen.fi/wp-content/uploads/2012/01/2011-04-12_29428-300x200.jpg" alt="" /></a>

    On visual it shows as it should, but when you preview it its all crooked as i explained earlier.

    Is there any other way to do it? For example divide the page in two halves somehow?

    K

    #69872

    Hi K,

    Can you add the images into the page and then provide a link to it?

    You could also try adding a new class to the style.css called link-page-images and give it the float right attribute. The final class would look like:

    .link-page-images{
    float:right;
    }

    Then you can add the .link-page-images class to the image in the Advanced Settings after inserting the image into the visual editor. Just click on the image to get the pop-up for it then go to the Advanced Settings tab and enter the class name into the CSS class box (make sure to delete alignnone if it is listed there).

    Regards,

    Devin

    #69873

    I have a similar issue with regular posts. When I insert images into the posts I can align them right, left and center in the editor, but when I look at the published posts all the images are aligned to the left. Any workaround for that?

    Here is an example http://www.tandlarsson.com/?p=319

    #69874

    Hi Thomas,

    Can you resend that link? I’m seeing a 404 error.

    Regards,

    Mya

    #69875

    Here is the link to my published dummy page: http://www.tandlarsson.com/thomas-testar/

    Now it works becuae I added a #content selector to the css –> #content .alignright

    Not too sure if it messes up any other pages, haven’t gotten around to check that yet.

    #69876

    All I have to do is add #content .algnright line to style.css?

    #69877

    Hey n0gear,

    It looks like its a good fix and should work fine for you. Just add #content before the .alignright class in the style.css.

    Thank you Thomas for the assist :)

    Regards,

    Devin

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘inserting pictures and align them to right side’ is closed to new replies.