Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #21132

    I’m setting up a website and I get this error occasionally (10% of the time) everything else seems to work. Any idea what is causing it or how to fix it?

    Fatal error: Class ‘WC_API’ not found in D:Hosting10570970htmlanderswp-contentpluginswoocommercewoocommerce.php on line 142

    #110554

    Additional information: I’m using Replete version 1.3.1 and woocommerce 2.0.2 This is a new install. I was worried that the woocommerce somehow didn’t get fully installed even though it said it was a successful install. Is it due to update issues?

    #110555

    hmmm… I just upgraded woocommerce to 2.0.3 and I can’t get the error to occur again. I guess maybe its fixed.

    #110556

    Well I have been getting the error again. So it is not fixed. Hopefully someone has an idea how to fix the problem. PLEEASE!

    #110557

    This error isn’t related to our theme and I can only give you some general tips.

    1) Try to increase the php memory: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP

    2) Try to deactivate all third party plugins

    3) Try to change the server or ask the hoster if they can provide more details (error logs, configuration checks, etc.).

    #110558

    I increased the memory to 128M and I still get the error. I downloaded a plugin to show me the memory usage and it currently displays 5.4MB. I’ll have to check with godaddy and see if they have a limit somewhere else.

    #110559

    Hey camillaanders,

    The issue may be godaddy unfortunately. Their hosting is pretty thin on what they actually provide for resources of a site. Check with them for sure and see if they can help in any way.

    Regards,

    Devin

    #110560

    Well of course Godaddy wasn’t really helpful. I did manage to resolve the issue by using woocommerce 1.6. instead of 2.0.3 Others had the same problem and used the older version to fix it. Maybe 2.0.5 will fix the issue. Haven’t tried it. For now the issue is resolved.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘intermittent woocommerce error when I try to load website’ is closed to new replies.