Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #7781

    Hey Dude.

    I have scoured the interwebs and this forum for answers, but to no avail. I hope you can shed the light I need. Here is the issue:

    I installed Abundance theme on WP 3.3.1, using GoDaddy hosting. All good. Then installed WooCommerce. After install, I receive Internal Server Error. PHP is set to 5.3, MySQL at 5.0, PHP limit set to 64Mb. I checked my error logs which show:

    [Mon Feb 13 21:39:12 2012] [error] [client ##.###.###.###] Premature end of script headers: index.php

    [Mon Feb 13 21:39:39 2012] [warn] [client ##.###.###.###] (104)Connection reset by peer: mod_fcgid: error reading data from FastCGI server

    What do you think is wrong? Is it server side?

    Thanks.

    m

    #59262

    Hey,

    this error message indicates that the server stopped processing the code in index.php. I think this is related to the allocated memory (64mb is not much). Try to increase the memory to 128mb ( http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP ). Make sure that you use the latest version of Abundance (1.2.1) and WooCommerce 1.4.x and maybe try to deactivate all other plugins – this will help you to find code conflicts.

    #59263

    Dude,

    Thanks for the advice. Turns out I had to turn on FastCGI on. Seems to be working. Appreciate the help.

    m

    #59264

    Glad that you found the problem. Status set to resolved.

    #59265

    hello michael, can you show us here how youturn on fastCGI on wampserver, i think i am having the same issue http://www.kriesi.at/support/topic/abundance-theme-not-working-on-localhost-using-wampsever-22-on-windows-7

    #59266

    I’d search for “Wamp Fastcgi” with Google. One of the first results is: http://wiki.ninjafocus.net/WAMP/FastCGI

    #59267

    yes i tried that but apache crashes.

    #59268

    whitepixel – did you get this to work?

    #59269

    Dude,

    Hate to bring back a once resolved issue, but I am receiving the Internal Server Error again. Site had been working fine for the past 2 weeks, but I made an edit on woocommerce settings page and received the error. With woocommerce activated my site only shows header now, nothing else. When I switch theme to TwenyEleven, site works fine and so does woocommerce. I haven’t upgraded Abundance or woocommerce yet (saw some of issues mentioned in the forum).

    php memory limit is at 64, cannot increase based on type of hosting I have. It seems woocommerce and Abundance are conflicting.

    Please advise. Thanks.

    m

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Internal Server Error After Install WooCommerce’ is closed to new replies.