Viewing 18 posts - 1 through 18 (of 18 total)
  • Author
    Posts
  • #18275

    Hi,

    I altered the design, and don’t want the responsive ( so not: ‘select page’) option.

    I tried different viewport settings but either the ipad or the iphone does not display correctly.

    What i want is for the website to scale to the width of the device and the option to zoom in.

    There is prob. a setting in the css that prevents this, spend hours on it. help!

    #98846

    anyone?

    #98847

    Hi hotspot,

    Can you post a link to your site? so we can check it further.

    Regards,

    Ismael

    #98848

    Hi Ismael,

    This is one of the websites that has this problem http://www.y u t r a i n.nl

    Hope you know what is going on…

    #98849

    any solutions?

    #98850

    Hi,

    I apologize, but I don’t understand what you mean by ” the option to zoom in.” I am picturing a magnifying glass over WooCommerce plugin shop item images but I think you meant something else?

    You also write that you turned off responsive but you later speak of ‘scale to the width of the device’.

    Looking at your site, I still see it is responsive. All the media queries seem to be there.

    So we can better help you, could you show an example website that has such behavior.

    Thanks,

    Nick

    #98851

    Hi Nick,

    Thanks for your reply.

    If you open at our website http://www.hotspotdesign.nl in iPad or iPhone you notice:

    - when it loads it loads the width of the website in ‘device width’, so you see the website completely

    - then the user has the option to zoom (also knows as pinch), so you can scale the website to be larger (zoom in)

    Do you understand a bit better what i mean?

    #98852

    Hi hotspot,

    Make sure that when you go to the Them Options> Layout & Settings >Responsive Layout the option for that dropdown is set to “Fixed Layout”.

    This will prevent the site from responding to the users browser or device size and will let an ipad/tablet zoom into the content.

    Regards,

    Devin

    #98853

    Hi Devin,

    It has that setting for one site. THe other site is the one of your other themes i used (not flagship) and does not has that option (only the option ‘boxed layout’). But both have the same problem.

    Hop you know what is going on.

    #98854

    Not all of the themes have the option to turn off the responsive design. For the one using Flagship you just need to simply turn the option off.

    For the other, we’ll need to know what theme it is using specifically to go forward.

    Regards,

    Devin

    #98855

    we did turn the option off in flagship but it is not working!

    PLease help this very urgent, the website is allready live!

    please email me julia [at] hotspotdesign.nl so i can email you the url (i cannot post it here)

    #98856

    sorry im so impatient, but its very urgent, any help is well appreciated.

    #98857

    Hi,

    Please provide us with a url in order for us to look at the changes you made to the code. So far we understand you customized the themes to partially remove the responsive aspect of the design and are experiencing issues with portrait / landscape transiton in mobile ios6 devies. If you would like please mail me the URL to usjahm (aaatttt) gmail (dddooottt) com

    Sorry for the delay.

    Thanks,

    Nick

    #98858

    Hi nick i emailed you yesterday morning, can you reply?

    #98859

    Hi,

    I have nothing from you but your email asking if I received an email which I initially deleted until I saw this post. Your first email never arrived.

    Thanks,

    Nick

    #98860

    Hee guys still no solution, any other moderator who can help me out?

    #98861

    Please resent Nick the url. Personally I’m unable to reproduce the issue with an ipad/ipod, etc. because I don’t own such a device. Flagship works fine on my Android 4.0 phone though. I’ll tag this thread for Nick.

    #98862

    Thanks Dude! I am on top of this one.


    As stated in email, you have one of your plugins injecting a second vieport meta directive on line 70 if you view source

    <meta name="viewport" content="initial-scale=1.0, user-scalable=no" />

    in addition to the original which is on line 14

    <meta name="viewport" content="width=device-width, user-scalable=yes, initial-scale=1" />

    You will need to edit the plugin that is doing that (i suspect the social plugin, as it is also throwing an error for using a bad google+ jquery ) and change the above meta tag so that the plugin just inject a single space ‘&nbsp ;’ (without the empty space between the single quotes.)

    You will also need to edit your header.php file and remove the above viewport on line 14 of source (though its probably on a differnt line, should be easy enough to find) and delete it. Paste the line below in its place:

    <meta name="viewport" content="width=device-width, initial-scale=1.0">

    Now open this page please https://github.com/scottjehl/iOS-Orientationchange-Fix/blob/master/ios-orientationchange-fix.js and copy that javascript and paste it in your footer.php right *before* the *closing body tag* … </body>

    Just dont forget to put it inside

    <script type="text/javascript">
    /* <![CDATA[ */

    /*paste the code from url mentioned in previous sentence here */

    /* ]]> */
    </script>

    Or you can use this plugin by Ben Wong , though I haven’t tested it, but it seems to be doing the same thing.

    http://benwong.me/downloads/ios-orientation-change-bug-workaround.zip

    Thanks,

    Nick

Viewing 18 posts - 1 through 18 (of 18 total)

The topic ‘ipad/iphone viewport? page not displaying correctly’ is closed to new replies.