Viewing 22 posts - 1 through 22 (of 22 total)
  • Author
    Posts
  • #166543

    Hi! I am having an issue with thumbnails for my blog posts. In some cases, a thumbnail picture appears, in others not. What could be the reason? I have not done anything differently between when it works and when it doesn’t. I usually take the same photo that is in the blog post and set it as a featured image. I don’t edit the photo into a smaller format but pick the photo that is usually 525 px wide and set it as featured. It worked for a while, but for the two last months it didn’t.

    See: http://magnuskahler.com – look at the right-hand side under “Latest Posts”. The two last posts have the generic icons; the ones before that have images as intended.

    Thanks in advance.

    #167926

    Hi beijaflor!

    Choices doesn’t actually use the Featured Media setting from WordPress. You should add your single image to the Featured Media meta box under the visual editor like you would add a slideshow. The theme then uses the first image from that to set all theme thumbnails.

    Cheers!
    Devin

    #168100

    Thanks, but that wasn’t was I was looking for. Thumbnail images do appear, BUT that same image also appear at the top of the post in a very large format. I prefer the photos to be inserted by myself in the post, in a smaller size (around 525px), in the way I have done for all the posts.

    What I don’t understand is how the thumbnails for some of the previous posts do appear? Have you changed this particular feature in one of your recent updates? As you can see, there are thumbnail images for some of the previous posts, without having done what you described above. But now that no longer seems to work.

    I don’t want to be forced to use the super-sized image for each post just because I want thumbnail images to appear.

    Please, advise.

    Cheers,
    M.

    #168817

    No, this is has always been in place. Whats happening is the other posts data has not been updated/processed by the theme.

    You can remove the large size image from being shown by adding the following css to your Quick CSS field in the styling tab of the theme options:

    
    #top.single-post .post-entry > .slideshow_container {
    display: none;
    }
    
    #169922

    That didn’t work. I added the code to the Custom CSS section, but when adding a photo to one of the posts, then it still appears as supersized above the post title.

    You wrote that for the other posts where thumbnails are working despite that I used the Set featured image option, it is becuase “Whats happening is the other posts data has not been updated/processed by the theme”. But why is that?

    If there isn’t a simple way to get the Set featured image function to work on my new posts, please send me another piece of coce that does remove the large image at the top of a blog post, when adding an image to the ‘slideshow’ section.

    #170330

    Hey!

    Correct me if I’m wrong but I don’t see any supersized images on top of the posts’ title. I’m sure Devin’s code will work. Can you give us a link to an example post with a supersized image? A screenshot will help.

    Best regards,
    Ismael

    #180340

    Hey Ismael!

    The site is live, so obviously I changed back when I noticed that the Custom CSS didn’t work. Hence, I didn’t want the same image duplicated when viewing a blog post, i.e. a supersized image on top and then the same image as included in the post straight after the blog post title.

    So the issue still remains…
    – I wish for an image to appear in the blog post thumbnail; see here as an example that in the last posts, there is no thumbnail image: http://magnuskahler.com (view the right-hand sidebar, Latest Posts)
    – I received a Custom CSS tweak from you – that did add a post thumbnail image BUT it also added a supersized image above the blog post title which I do not want. The only change I want is for the post thumbnail image to appear.

    Could you please review and double-check the CSS code and provide me with a new code that I can try out.

    Another change I wish to make is for just blog post excerpts to be shown when visiting http://magnuskahler.com/blog as opposed to the full posts as is now the case. And how do I tweak the actual length of the post excerpts?

    Thanks in advance.

    M.

    #180945

    The css I gave you *removes* the large image slider above the post. The theme adds it by default when a post as a featured image.

    If it isn’t doing that I would need to see the site and a post live with the featured image set and the css in place in your Quick CSS or custom.css.

    #181103

    I have added code to the Custom CSS, and added an image to the Featured Media section, and voila, you can now see that image being shown also on top of the post title:

    http://magnuskahler.com/are-your-most-visible-brand-carriers-boosting-or-hurting-your-brand/

    Can you please double-check your Custom CSS code?

    Thanks.

    #181434

    Hi!

    Please add this on your custom.css or Quick CSS:

    .single .slideshow {
    display: none !important;
    }

    Please remove browser cache then reload the page.

    Cheers!
    Ismael

    #181565

    Now that worked fine!

    Shall I still keep the previous code that had no effect, i.e. do these two different snippets somehow work together? It seems as if I only need the latter code, which I just received from you.

    Cheers,
    M.

    #181621

    I just noticed that it actually does NOT work yet. It works on single post pages, but when going to:
    http://magnuskahler.com/blog , you see two images per post. How can I get rid of the supersized image also on the blog landing page?

    Cheers.

    #181622

    Hey!

    Please add following code to Quick CSS as well

    .blog #top .slideshow_container ul { display: none; }

    Best regards,
    Yigit

    #181624

    By the way, what is the width in pixels of the supersized image?

    #181626

    Hi!

    Size of slideshow that appears on top is 610x344px

    Regards,
    Yigit

    #181632

    Strange, the slideshow images are still there even though I emptied the browser cache: http://magnuskahler.com/blog

    By the way, how do I change so that the posts are only shown as excerpts on the blog landing page?

    #182001

    Hey!

    Do you mind creating a temporary admin login and post it here privately?

    Regards,
    Yigit

    #182074

    Hi Yigit! I’d like to avoid providing an admin login if possible. Could you please have another go at it? Here are the snippets you have provided me with. I think that only the second one is working. What could be the equivalent of that one, but instead for single blog posts, for the blog landing page where a number of posts are listed (http://magnuskahler.com/blog )? Does the slideshow container have a different name on the blog landing page?

    Cheers,
    M.

    —–

    #top.single-post .post-entry > .slideshow_container {
    display: none;
    }

    .single .slideshow {
    display: none !important;
    }

    .blog #top .slideshow_container ul {
    display: none !important;
    }

    #182080

    Besides the slideshow issue, how can I change so that only excerpts of each post is shown on the blog landing page?

    Cheers.

    #182081

    Hey!

    Please try following code

    #top .slideshow_container { display: none!important; }

    Then flush browser cache and refresh your page a few times

    Cheers!
    Yigit

    #182101

    Awesome, that worked! :-)

    Now I’ll still have to add the same image twice, first to insert the image into the post, second to insert the image in the slideshow section in order for a image thumbnail to be generated.

    (I’ll illustrate something by removing the Custom CSS for now:)
    If using your slideshow functionality, I get a 610 px wide image here:

    http://magnuskahler.com/blog/

    But when going to the single post view, I get a huge image (despite it being a Standard post) here (in the demo, the image is not that huge when using the Standard post format):

    http://magnuskahler.com/how-an-authentic-meaningful-and-emotional-brand-story-drives-growth/

    Is there a way for the 610 px-wide image to be displayed both on the blog landing page and the single blog post view? If so, maybe I would choose that as an option in order not to have to add the same image twice every time I post. But I would need to avoid that huge single post image since the resolution will often not be large enough to allow such image blow-up.

    #183153

    Hey!

    You can add following code to Quick CSS to keep image width at 610px

    #top .slideshow { width: 610px; }

    Best regards,
    Yigit

Viewing 22 posts - 1 through 22 (of 22 total)

The topic ‘Issue with blog post thumbnails’ is closed to new replies.