Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #10018

    Hello,

    I have a critical issue here.

    All my product category pages have the following meta:

    <meta name=”robots” content=”noindex, follow”/>

    This means Google doesn’t index my product categories, which is extremely bad.

    This is one of my product category pages:

    http://www.diycoffee.com/products/

    I am using Yoast Seo WordPress plugin and everything works fine, only the product category pages do not work like they should.

    As you can see, all product pages have the good <meta>.

    I already disabled several plugins that could cause the issue. Also disabled Yoast Seo. That was not the problem. So the issue is theme related. What is the issue here?

    #66598

    Hi Andredewaal,

    I believe this is actually WooCommerce that sets the pages to noindex,follow. You can try using: http://wordpress.org/extend/plugins/robots-meta/

    #66599

    Hi Devin,

    I actually already tried that :)

    Doesn’t work though. Also, it is the same functionality that is already built in Yoast Seo plugin.

    #66600

    Hi Andredewaal,

    This is no response on your question, but maybe you can help me.

    1) Looking at for example http://www.diycoffee.com/product/friis-coffee-vault-16-ounce-stainless-steel/

    I noticed the price is listed under the product description:

    Friis 16-Ounce Coffee Vault, Stainless Steel

    Price: $21.25

    How did you get it there ?

    2) Which plugin do you use for social media (twitter/ facebook etc) ?

    Your help is appreciated.

    #66601

    Someone please help me out here? I am about to throw my laptop out of the window! This is driving me insane.

    @digiaudio: plugin for social media buttons is Sharing is Caring plugin. PHP is your friend :)

    #66602

    Thanks Andre !

    Concerning your issue, I bet you turned this on . . . wp-admin/options-privacy.php (in the backend of wordpress . . . settings/ privacy)

    >> Sta zoekmachines toe om je site te indexeren. (guess you understand this, since you’re dutch ;-)

    #66603

    No, that is not on. Of course not… It has to be either in the theme settings or in WooCommerce settings.

    How much did you want to bet? Lol ;)

    So, anyone from the support theme that can help me out here?

    #66604

    Lol ;-)

    Good luck find a solution !

    #66605

    Hi Andredewaal,

    You can force the avia framework to make all pages “index, follow” by opening framework>php>function-set-avia-frontend.php then editing line ~312 from noindex to index.

    #66606

    Yes! That is the solution!

    I would have never ever figured that out by myself, i spent hours finding the problem.

    Thanks so much!!

    #66607

    Glad we figured it out :)

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Issue with NoIndex on product categories’ is closed to new replies.