Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #12132

    I’ve been having terrible trouble with Permalinks and the Error 404 page. I’ve asked for solutions from WordPress support and my hosting provider, to no avail, and both have now suggested it could be a theme issue.

    The problem, initially, was that in Settings>Permalink, only in Default and Numeric would Categories, Tags and Posts show correctly, while, in other settings, clicking on Posts would show on correct page but clicking on Categories and Tags brings up 404 (Page Not Found) Error. Only if I use Settings>Permalinks>Custom Structure and a mixture of Numeric and Post name – i.e. /archives/%postname%/ – can I get an acceptable URL, like:

    a) Posts: http://golovegreece.com/archives/aegina

    b) Tags: http://golovegreece.com/archives/tag/aegina/

    c) Categories: http://golovegreece.com/archives/category/cities/

    I don’t really want ‘archives’ in the URL, but I can live with it to avoid the Error 404 page.

    However, today I was trying out the search feature in top right corner of the home page on my site – http://golovegreece.com/; and if I put in something that will return more than one page, for example, ‘Athens’, while page 1 of Search Results brings up the relevant results, if I try to bring up page 2 or page 3 of Search Results (bottom left corner), I get a 404 (Page Not Found) Error. Only in Default does the search feature work correctly; in all other modes, I get the Error page. I’ve tried ‘flushing’ the settings, but to no avail.

    Is this something you can help me with?

    Thanks

    #74437

    Hello,

    On Permalink > custom structure. Try to input the same format twice or thrice and see if it works. Sometimes it doesn’t work on the first try.

    Regards,

    Ismael

    #74438

    Unfortunately, Ismael, that doesn’t do the trick. I’ve noticed now that the changing pages function doesn’t work anywhere and not just in the Search pages function; by which I mean the first page in any series of pages will show correctly, but any subsequent pages will show as Error 404. Thus, if you go to the Home Page of my site – http://golovegreece.com/ – and try in bottom left corner of blog to go to page 2, an Error 404 page will appear. The URL for the error page is: http://golovegreece.com/page/2/. Only in Permalink>Default does changing pages work, with the URL showing in the case of the Home Page as: http://golovegreece.com/?paged=2.

    This is a big problem, and I’d really appreciate a solution, if it’s a theme issue.

    Thanks

    #74439

    Hi demozeno,

    It may or may not be theme related but most likely not. Permalinks can be a bit finicky sometimes.

    You can test it for sure by changing to the default wordpress theme (twenty eleven will work) and trying pagination (switching from page 1 to 2 to 3).

    Here are some basic troubleshooting tips from the wordpress codex that might help as well: http://codex.wordpress.org/Using_Permalinks#Fixing_Permalink_Problems

    Regards,

    Devin

    #74440

    Hello Devin. Thanks for getting back. I think you’re right and that it’s a WP not a theme issue. Navigation works fine with the theme in local host and when I tried with 2011 on external host, then I had the same problem with navigation links going to 404. Apologies that I keep bringing up issues – I’m a WP novice, still figuring it all out. The theme is great and I enjoy working with it.

    #74441

    I’ve boiled down my problem to ‘custom permalinks causing pagination to fail’.

    The problem goes like this:

    Pagination only works when permalinks are set to Default and page URL looks like this: http://golovegreece.com/?paged=2.

    Pagination doesn’t work (goes to 404 error page) when permalinks are customised and page URL looks like this: http://golovegreece.com/page/2/

    I’ve googled and googled and asked a dozen questions in various support forums, but still no joy.

    However, I saw here (http://wordpress.stackexchange.com/questions/6343/wordpress-pagination-with-custom-post-type) a possible solution, referring to modifying the query code.

    I have no idea what ‘query code’ is, and I looked for it in all the theme and WP files, but couldn’t find it. It seems to go something like this:

    global $paged;

    global $wp_query;

    wp_reset_query();

    $per_page = get_option(‘posts_per_page’);

    $cat_cars = get_term_by(‘slug’, ‘cars’, ‘category’);

    $page_links_total = ceil($cat_cars->count / $per_page);

    $paged = (get_query_var(‘paged’)) ? get_query_var(‘paged’) : 1;

    So, my question is: could you tell me in which file I could find this query code. Thanks

    #74442

    Hey demozeno,

    The query is in the index.php but I’m not sure what you have posted is necessarily relevant to the issue.

    I’ll ask some of the other support crew to take a like however as I may be missing something.

    Regards,

    Devin

    #74443

    Hello Devin

    yes, I’ve concluded that the problem is not to do with the query either; in which case, I’ve completely run out of ideas as to how I can get custom permalinks to work. I appreciate that this is not a theme issue – and I don’t want to take up your time by asking about non-theme issues – but any suggestions as to how I can escape default permalinks would be very gratefully received. Thanks a million.

    #74444

    The only other thing I can think of (as it just solved the same issue for someone else) is to disable all plugins you have running, refresh your permalink settings a few times and save them. Then, with only wordpress and the theme running, test things out.

    Regards,

    Devin

    #74445

    Thanks Devin. I will try this… again, since I’ve tried it before, without success. Maybe this time, I’ll cross my fingers.

    #74446

    Let us know how it goes or if you found a different solution. Always helps to have a resolution before a topic is closed out :)

    Regards,

    Devin

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Issue with Permalinks, 404 (Page Not Found) Error’ is closed to new replies.