Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #22277

    The javascript seems to be fine on every admin page, except on the post edit page. If you try to edit a post, all of the javascript seems to be broken, none of the link items that use javascript work.

    When looking at the resources, there is an error with jquery.min.js

    “Uncaught error: cannot call methods on sortable prior to initialization; attempted to call method ‘toArray’”

    Thoughts?

    #115173

    Hi!

    I can’t reproduce this issue on my test server – maybe a third party plugin triggers the js error? Try to deactivate all plugins.

    Regards,

    Peter

    #115174

    I don’t believe this is generally an issue for most who have purchased, but I feel for completeness that it’s also important to add that I have also encountered this error myself, with no local results so far in remedying it since my installation of the theme last weekend.

    For myself, I believe it began roughly 2-hours into my becoming accustomed to the new theme options with the advanced-editor, as all was working fine, and I can only assume then stalled after simply updating one of my pages, but I didn’t actually notice the non-functioning javascript until a bit later on, when attempting another page edit, as the popup window for the “advanced-editor” no longer appeared when clicking the button to enter that editing-mode, although the button itself does visually switch from “advanced”, to “default” when selected.

    I can verify that this state remains as well even with the removal/deactivation of all 3rd-party plugins I have installed, the deactivation of all page-widgets I routinely have in use, as well as browser, and wordpress cache-cleaning. (*To note, the issue remains regardless of using FF/IE/CHROME, and a fresh reinstall of the latest, updated version)

    Also in regard to assisting with any troubleshooting, and just as fm005 states in his post, all other elements of javascript (both theme-integrated, and wordpress-centric) work flawlessly, and without incident as always.

    Again, this appears to be a very small use-case in regard to the other issues, if any at all, that users are experiencing at this time, but thank you to anyone who may have a possible solution for us to explore here.

    #115175

    Hey!

    If you’re still experiencing the issue please create me a wordpress admin account and send me the login data to: (Email address hidden if logged out) – we’ll look into it.

    Best regards,

    Peter

    #115176

    Hello again Dude,

    Just to relay a minor update to this issue, I wanted to inform that I was able to successfully add the advanced-layout editor options to my blog posts section after following the instruction given by Nick in his short Vimeo video: “How to add Layout-Editor to custom post types, and posts”, yet the issue where the option for the editor is visible, but still does not function on any level while editing my “Pages” is ongoing and very perplexing.

    Oddly enough, the advanced-editor also continues to function flawlessly with “Portfolio” section posts, which has me wondering if the reason for this happening is very minor, versus major.

    #115177

    Hi SamuelB,

    If you have ever had any of the caching plugins installed, you need to completely delete the folders from your plugins folder for them to not effect the site still.

    It could be something like that with another plugin that was previously installed or even a local browser add on that may, for some reason, only be effecting pages.

    Other than, I have no idea what could be causing such inconsistent issues

    Regards,

    Devin.

    #115178

    I’m having the same issue, javascript is broken for Edit Post, but does work for Page & Portfolio edit. Avia Builder doesn’t show, and other modules don’t open such as SEO module and Screen Options.

    I also tried deactivating all plugins, still broken

    I also have the same error in firebug:

    Uncaught Error: cannot call methods on sortable prior to initialization; attempted to call method ‘toArray’ jquery.js?ver=1.8.3:2

    v.extend.error jquery.js?ver=1.8.3:2

    (anonymous function) jquery.ui.widget.min.js?ver=1.9.2:5

    v.extend.each jquery.js?ver=1.8.3:2

    v.fn.v.each jquery.js?ver=1.8.3:2

    e.fn.(anonymous function) jquery.ui.widget.min.js?ver=1.9.2:5

    (anonymous function) postbox.js?ver=3.5.2:129

    v.extend.each jquery.js?ver=1.8.3:2

    v.fn.v.each jquery.js?ver=1.8.3:2

    postboxes.save_order postbox.js?ver=3.5.2:128

    $.AviaBuilder.place_top avia-builder.js?ver=0.2:121

    $.AviaBuilder.set_up avia-builder.js?ver=0.2:104

    $.AviaBuilder avia-builder.js?ver=0.2:93

    (anonymous function) avia-builder.js?ver=0.2:1303

    l jquery.js?ver=1.8.3:2

    c.fireWith jquery.js?ver=1.8.3:2

    v.extend.ready jquery.js?ver=1.8.3:2

    A

    Dude, I created an admin account for you, as you instructed for Samuel. If you get a chance to take a look that would be great. The site is not live yet, so no worries deactivating anything.

    Thanks

    #115179

    Hi giannag,

    Are you using 1.7.1 version of the theme? If not make sure to re-download the theme files and update your live site. I’ll flag the topic for Dude so he has it in his queue since you already sent him your login details.

    Regards,

    Devin

    #115180

    Hey!

    I forwarded the login data to Kriesi.

    Best regards,

    Peter

    #115181

    Gracias, if you need an ftp, let me know

    #115182

    The post has also been tagged for Kriesi so if he is able to find the issue he will most likely post here.

    I’m going to close the topic until then however so that we can approach any similar but perhaps not exact issues separately.

    Regards,

    Devin

    #115183

    Hey giannag!

    I wasnt able to find whats causing the issue on your server. If you want me to dig further into the problem I will need access to your ftp data so I can start enabling and diabling certain scripts to see what is causing the issue.

    Cheers!

    Kriesi

    #115184

    I set an ftp to (Email address hidden if logged out) as that is the email I have for you guys.

    Thanks so much!!!

    #115185

    Hey!

    I forwarded the login data.

    Best regards,

    Peter

    #115186

    I did a “Re-install Now” of WordPress 3.5.2, via WordPress’ Updates admin (/wp-admin/update-core.php) and that fixed the issue. The post editor is working fine now.

    I appreciate the attention and dedication of the Kriesi team in addressing the issue.

    Thanks guys

    #115187

    Hey,

    Glad it is fixed. :)

    Cheers,

    Ismael

Viewing 16 posts - 1 through 16 (of 16 total)

The topic ‘Javascript broken on POST EDIT page’ is closed to new replies.