Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #28158

    Hello.

    I’ve installed yesterday the Enfold theme (which is awesome!) and also switched from qTranslate to WPML. Everything works fine, as far as I recognized. Just one thing I just saw. I have Javascript in my RSS Feed. And no RSS reader likes it… how do I get it out there? And why is it there?

    Cheers

    Gordon

    Here the feed:

    _______________________________________________________________________

    <script type=’text/javascript’>

    /* <![CDATA[ */

    var avia_framework_globals = avia_framework_globals || {};

    avia_framework_globals.frameworkUrl = 'http://www.***.com/wp-content/themes/enfold/framework/';

    avia_framework_globals.installedAt = 'http://www.***.com/wp-content/themes/enfold/';

    avia_framework_globals.ajaxurl = 'http://www.***.com/wp-admin/admin-ajax.php?lang=de';

    /* ]]> */

    </script>

    <?xml version=”1.0″ encoding=”UTF-8″?> <rss

    version=”2.0″

    xmlns:content=”http://purl.org/rss/1.0/modules/content/”

    xmlns:wfw=”http://wellformedweb.org/CommentAPI/”

    xmlns:dc=”http://purl.org/dc/elements/1.1/”

    xmlns:atom=”http://www.w3.org/2005/Atom”

    xmlns:sy=”http://purl.org/rss/1.0/modules/syndication/”

    xmlns:slash=”http://purl.org/rss/1.0/modules/slash/”

    #136689

    Hi Gordon,

    Can we see your site live so we can pull up the feed? That is the debug information which should only be getting spit out as a comment in the source of your page but my guess is there is a plugin hooking into the output at the same spot which is causing the two to merge (or something like that).

    You could try this to just remove it form getting output if you want to try a quick fix: Add the following at the end of your functions.php

    remove_action('wp_head','avia_debugging_info',1000);

    Regards,

    Devin

    #136690

    Hi Devin,

    thanks for your reply. Unfortunately this line wasn’t working.

    My feed url is: http://www.gordonzube.com/feed

    I could figure out which plugin it is. It’s ‘WP Minify’. But I would like to keep it. Can we solve the problem without that I have to delete the plugin?

    Cheers,

    Gordon

    #136691

    Tbh I’m not familar with Wp Minify and it seems to be outdated and broken ( see http://wordpress.org/plugins/wp-minify/ ). You can try w3tc: http://wordpress.org/plugins/w3-total-cache/ or http://wordpress.org/plugins/bwp-minify/ instead.

    #136692

    Hey! We use the second minify plugin that dude postet but the next version of the theme should fix the issue. I added a check for that output to not be added if on a wordpress feed.

    Would recommend better-wp-minify anyways :)

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Javascript in the RSS Feed’ is closed to new replies.