Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #21627

    Hi there,

    I enabled the switcher to show in both my menus (navigation for the english version of my website, “menu” for the dutch version of my website) in the WPML languages options. Earlier today they did show up in both my menu and the footer. Then, when I disabled them being available in the footer, they wouldn’t show up anymore in both menus. I installed them again, but now they just won’t show up…

    #112515

    Hey surfcaatje,

    Can we take a look at the site live with the option turned on?

    Regards,

    Devin

    #112516
    #112517

    Try to add replace following code in header.php:

    get_search_form();

    with:

    do_action('icl_language_selector');

    get_search_form();

    This code will call the language switcher and should force wp to display it.

    #112518

    That worked, however, the switcher floats on the left side of the header. I’d like the switcher to be on the right side, where the “search bar” is now. The search bar can be removed, I don’t need it, so the switcher can go there instead.

    And if possible, I’d like only the flags to show up, next to each other:

    “Rss icon” “facebook icon” “flag” “flag”

    like that.

    Thanks!

    #112519

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #lang_sel_list {
    float: right;
    width: auto;
    position: absolute;
    top: 2px;
    right: 0px;
    }
    #lang_sel_list li {
    width: 75px;
    }
    #lang_sel_list ul {
    width: 150px;
    }

    Regards,

    Devin

    #112520

    Thanks, that worked

Viewing 7 posts - 1 through 7 (of 7 total)

The topic ‘Language switcher not showing’ is closed to new replies.