Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #17442

    Hi

    Firstly thanks for creating such a wonderful theme!

    Unfortunately I am having a difficulty with the theme when I want to increase the size of the logo beyond the size that the theme options recommends. When I do it the positioning is fine, the problem comes when I reduce the window size down to that of (around) an iPad/tablet screen width. The navigation clashes by going over the logo. If you visit http://dev2.heartwoodburners.co.uk/ you will see what I mean.

    As part of my investigation into why this might be happening I tried using the recommended logo size and created a longer primary navigation – of about 8 items – to see if the same thing happens and it does. It seems there is something missing from the CSS or code to allow this to happen whether recommended logo size or not.

    It would be great if I could (1) get the navigation to flow on to two lines in order to remedy this responsive issue (preferred) or (2) have the mobile device menu swap out from the standard navigation at a slightly higher window width (at the moment it seems to happen around 767px.).

    Can you give me an idea of how I could remedy either (1) with the stylesheets or where to find the responsive navigation element in the files in order to achieve (2)?

    Thanks so much in advance – you will be saving me a load of trouble. I have been looking for a work around all day.

    Best regards

    #95480

    Hi domchocolate.

    Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    @media only screen and (max-width: 989px) and (min-width: 768px){
    .main_menu {top: 80%;}
    }

    Regards,

    Devin

    #95481

    Lovely thanks!!!

    #95482

    Hi domchocolate,

    Glad the Devin helped you. :)

    Cheers,

    Ismael

    #95483

    Yeah it works fine now. Can I sneak in one more question? I have the greyscale hover effect turned off in the portfolio preferences – which works fine – but when I click on a category from the single portfolio page to an ‘Archive for:’ page the greyscale effect reappears (see http://dev2.heartwoodburners.co.uk/portfolio_entries/12mm/). Can you tell me how to switch this off?

    Thanks again!!

    Best regards

    Dominic

    #95484

    Hey Dominic,

    As long as its only one more :)

    This should do the trick, though I’ll have to suggest to Kriesi that he add in a theme wide option in the admin. Try adding the following CSS to your Quick CSS (located under the Styling Tab in the theme options) or the custom.css file in the css folder of your theme files:

    #top.archive.tax-portfolio_entries .greyscale-image {
    display: none;
    }

    Regards,

    Devin

    #95485

    Thanks again – worked a treat.

    One very last one I promise. On the same page (see http://dev2.heartwoodburners.co.uk/portfolio_entries/12mm/) it is calling a sidebar and therefore a widget. I don’t want this to appear. I have tried removing the “get sidebar” out of archive.php and template-archive.php but to no avail.

    There is also nothing you can do in the preferences.

    Best

    Dominic

    #95486

    I’m not sure why you are getting that as on my test install running Eunoia 1.3 I’m not getting a sidebar or any other content on a portfolio archive page.. It could be a bug that has since been fixed in one of the past two releases. I would suggest updating the theme and see if that resolves it.

    If you’ve made any customization to the theme files themselves, make sure to back them up so they can be re-applied after you upload the new files.

    You can download the most recent version from your Downloads on Themforest and then install the update in the same way you first installed the theme.

    Regards,

    Devin

    #95487

    Thanks Devin – I will download the latest version. I don’t suppose you know which files I should replace that drive the sidebar on the archives pages rather than the whole theme – I reckon I”ll have to redo a lot of the customisation

    #95488

    You can take a look at the version.rtf that comes with the whole package and it will tell you what has been updated. The big one with 1.2 was the whole framework folder. There is also an update to includes>helper-template-dynamic.php dealing with sidebars which may be what you are looking for.

    Since you are going from 1.0, you’ll also have to check through everything done in 1.1 as well.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Larger logo and responsive navigation/menu’ is closed to new replies.