Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #25652

    Hello Kriesi. First of all awesome theme you’ve made here! Hat off!

    And now my problem:

    On a local install (MAMP test server) I’ve got a problem with LayerSlider. It doesn’t work because it says this: ” LayerSlider: old jQuery issue – It looks like you are using an old version (1.10.1) of the jQuery library. LayerSlider requires at least version 1.7.0 or newer … etc. etc.”

    I know jQuery 1.10.1 it’s the latest available with support for IE 6+. Haven’t touched the inner workings of the theme. The WP install is fresh – WP 3.6-beta4-24534.

    WordPress 3.5.2 comes bundled with jQuery 1.10.1

    Any ideea how to fix it?

    I’ve already tried to deregister the default jQuery and load it from the Google CDN (an older jQuery version) and it didn’t work.

    Later edit:

    Apparently another sip of coffee and added ” ; ” in the right place and I’ve fixed.

    What I did:

    added this snippet:

    Code:
    wp_deregister_script( ‘jquery’ );
    wp_register_script( ‘jquery’, ‘http://ajax.googleapis.com/ajax/libs/jquery/1.9.1/jquery.min.js’, array(), null, in_footer );

    inside functions.php – in the ” avia_register_frontend_scripts() ” function.

    #127722

    Glad you fixed it. Please note that “WordPress 3.5.2 comes bundled with jQuery 1.10.1″ is not true but it uses jQuery 1.8.3. Tbh I even doubt that WP3.6 will use jQuery 1.10 and I guess they’ll stick with the 1.9.x branch. However maybe a plugin overwrites the default jquery file…

    #127723

    @Dude, double checked and you are correct, WP 3.5.2 comes bundled with jQuery 1.8.3. I think I was browsing the wrong svn branch when I say jQuery 1.10.1 for WP 3.5.2

    And at least WP 3.6-beta4-24534 has jQuery 1.10.1 bundled, and my current test bed for Enfold is vanilla WP 3.6-beta4-24534 with no additional plugins.

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘LayerSlider – old jQuery issue’ is closed to new replies.