If you have troubles since the update to WordPress 4.5 please read this post before opening a new thread.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #25545


    Please: I’m trying to set up a page with small slider on top, like in http://www.kriesi.at/themedemo/?theme=enfold on “Pages”

    I tried to:

    – use the slides that were already there like “Why Enfold – Small Header”

    – duplicate and modify one

    – make one myself

    I get no page but this warning:

    Fatal error: Call to undefined function layerslider_init() in /htdocs/public/www/wp/wp-content/themes/enfold/config-templatebuilder/avia-shortcodes/slideshow_layerslider.php on line 121

    Link to page: http://www.akab-lsp.com/wp/?page_id=531

    I don’t understand what may be the problem, can you help me?

    Thank you very much,



    Hi Lucia,

    I’ve not run across that error before and looking at the line where the error seems to stem from doesn’t seem to be related. I’ve tagged Kriesi on the topic as well as the head of support to take a look.

    When setting up that page, was it based on imported dummy data or built from scratch? Are you able to add a layer slider to a layout with no other elements or is it just on a page where you have also added elements to the layout below/above it?




    Hi Devin,

    In setting up the theme I don’t recall having imported dummy data, the page was created like: Pages/Add new

    In setting up the page I used Advanced Layout Editor and just choose Media Elements, Advanced Layer Slider and than found out there were already two sliders ready (I don’t know if that’s the dummy data) so at first I duplicated one of them and changed a few things.

    When I tried to view the page I got the Fatal error message. Than I tried the few things described above. The content of the fatal error is always the same.

    There were no other elements in the page but lately I addeed a Text Block below the layerslider (just in case) with a couple of words in it. Fatal error is still showing.

    Thank you for your answer, please feel free to suggest any other solution, if it can help I will try them out.



    1) Please try to re-upload the wp-contentthemesenfoldconfig-layersliderLayerSlider folder and make sure that the folder permission is set to a reasonable value like 755. Make sure that the wp-contentthemesenfoldconfig-layersliderLayerSliderlayerslider.php file exists on your server.

    2) Try to increase the allocated php memory to 128M: http://codex.wordpress.org/Editing_wp-config.php#Increasing_memory_allocated_to_PHP


    Hi Dude and thank’s

    I’ve done what you suggested.

    1) define(‘WP_MEMORY_LIMIT’, ‘128M’);

    2) Checked the folder permission, it was 755

    Had to publish the site, so here’s the new link to the test page http://www.akab-lsp.com/test-advslider/

    Fatal error is still showing.

    In setting up the page I used Advanced Layout Editor and choose Media Elements, Advanced Layer Slider and Enfold – beautiful theme ever

    And added a textblock with dummy text below

    Layout No sidebar

    Header Settings Don’t display the header

    Footer Settings Default layout

    Here is another page: http://www.akab-lsp.com/test-advslider2/

    In setting up this page I used Advanced Layout Editor and choose Media Elements, Advanced Layer Slider and Enfold – beautiful theme ever. Made no other changes.

    Pease any other suggestion will be welcome, Advanced Layer Slider is one of the more beautiful features of Enfold theme




    Looks like the page are all working now without the error?



Viewing 6 posts - 1 through 6 (of 6 total)

The topic ‘LayerSlider WP Fatal error’ is closed to new replies.