Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
    Posts
  • #17221

    Hi,

    I translated few pages and noticed that Layout, Featured media & Slideshow Options :

    * are not copied when creating the translation (Translated pages were made with WPML Duplicate option)

    * are not saved when updating the page (they have default values)

    I’m using:

    - WP 3.4.2

    - WPML 2.6.0

    Is there specific configuration of the theme/WPML that I should made?

    Regards

    #94612

    Hey!

    Please check if the admin page language (dropdown at the top) is set to the current page/entry language.

    Regards,

    Peter

    #94613

    Thanks for the tip!

    I was editing the content & translations in the multiple tabs/windows. I have open the same document in multiple languages in different tabs/windows and then I was checking the content between translations/windows.

    The reason I was doing this is because the Propulsion theme (Avia framework) data was not copied between translations – despite that I used the WPML Translation “duplicate” option. So the “Featured media” gallery, slideshow & layout data didn’t make it to the translations and I had to copy & check the data between different translations.

    The admin page language (dropdown at the top) and Language in the sidebar was shown correctly.

    All the NON Propulsion theme (Avia framework) data was saved correctly!

    The solution to my problem was to NOT to have opened multiple tabs/windows in different languages.

    Probably manually selecting already correctly selected language from the admin dropdown would do the trick to.

    I think there are two bugs here:

    1.) Propulsion theme (Avia framework) data is not copied over to translations when using WPML Translation “duplicate” option.

    2.) The Propulsion theme (Avia framework) data is not saved when you have open multi tabs/windows with different languages. At the same time all other “native” WP content is saved without any problem.

    It would be great if at least one of those problems could be fixed.

    Please let me know if I can look forward for patch that would solved the issue.

    Thank you for your help and pointing me in the right direction.

    Best regards.

    #94614

    I’ll mark this one for Kriesi but very likely we can’t solve this issue because of technical limitations. Probably WPML sets a cookie or a session variable to determine which language is currently selected and this cookie/seesion variable affects the entire browser environment and thus ALL tabs or browser instances.

    #94615

    PS:

    Yes, but interesting is that “native” WP content does not have any problem at all with that (editing in multi tabs/windows).

    If Propulsion theme (Avia framework) data would be copied over to translations when using WPML Translation “duplicate” option it would really help.

    #94616

    Hey dasBIOS,

    If I remember correctly, Kriesi actually set it that way to not duplicate so that the options were able to be done indivudally without any possible complications. I may not be completely correct but when Kriesi gets back to updating we can check further on it one way or another.

    Regards,

    Devin

    #94617

    OK. Please let me know.

    THX!

    #94618

    Post tagged for Kriesi :)

    Regards,

    Devin

    #94619

    I am not sure if that can be fixed. It seems that the duplicate option doesnt copy all the custom fields of a post to the new post. (slideshow settings etc are stored in custom fields)

    Not sure if this is an overseight of WPML or a problem with the theme. Have you already contacted the WPML team about the issue? They of course know the WPML plugin much better than we do so might help much faster.

    Meanwhile I will have a look at it and see if I can up with a simple solution…

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘Layout, Featured media & Slideshow Options are not saved on translations’ is closed to new replies.