Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #29272

    Hi, when the lightbox is open and there is only one slide, the navigation arrows still show up. This doesn’t make a lot of sense because there is only one image to view.

    This problem applies to the Blasted Logo at marissahile.com

    Thanks.

    #140230

    Hi mlhile,

    As far as I know its a quirk of the prettyPhoto javascript plugin. I’ll tag the topic for the head of support but I don’t know of any actual fix for it to change the behavior.

    Regards,

    Devin

    #140231

    Yes, it’s indeed a bug in the prettyphoto script. To fix it download the uncompressed code of the lightbox here: http://www.no-margin-for-errors.com/demos/prettyPhoto-jquery-lightbox-clone/prettyPhoto_uncompressed_3.1.5.zip and unzip the file. Then replace /wp-content/themes/choices/js/prettyPhoto/js/jquery.prettyPhoto.js with the uncompressed js file from prettyPhoto_uncompressed_3.1.5.zip. Now open up /wp-content/themes/choices/js/prettyPhoto/js/jquery.prettyPhoto.js and replace

    $pp_pic_holder.find('.pp_previous, .pp_nav .pp_arrow_previous').bind('click',function(){
    $.prettyPhoto.changePage('previous');
    $.prettyPhoto.stopSlideshow();
    return false;
    });

    with

    if(pp_images.length < 2)
    {
    $pp_pic_holder.find('.pp_previous, .pp_nav .pp_arrow_previous, .pp_next, .pp_nav .pp_arrow_next').hide();
    }

    $pp_pic_holder.find('.pp_previous, .pp_nav .pp_arrow_previous').bind('click',function(){
    $.prettyPhoto.changePage('previous');
    $.prettyPhoto.stopSlideshow();
    return false;
    });

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘Lightbox navigation’ is closed to new replies.