Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #669713

    I’ve got Blog Post element on my front page. The links are not active on excerpt. How can I set them active?

    #671150

    Hey emiliaro,

    Thank you for using Enfold.

    I checked the frontpage but I don’t see the word “tästä” anywhere in the posts. We tested this on our installation and the blog grid layout display the link properly in the excerpt.

    Best regards,
    Ismael

    #671190

    Hi,

    It seems that the customer had updated posts and the “tästä” post went out of the frontpage.
    Now there is a new post. The word “täältä” should be a active link. Could you please check this again. Thank you.

    #672437

    Hi,

    Edit each posts then specify the excerpt manually. If you can’t find the Excerpt module, enable it in the Screen Options.

    Best regards,
    Ismael

    #672607

    Hi,
    In the excerpt you have to write some html to enable links. Customer cant do that, so it would be nice if the excerpt (which comes directly from the post area) activates links as they are displayed on the post page.

    #673973

    Hi,

    This is possible but you have to modify the parent theme files. Edit the config-templatebuilder > avia-shortcodes > postslider.php file. Look for this code around line 320:

    $prepare_excerpt = !empty($entry->post_excerpt) ? $entry->post_excerpt : avia_backend_truncate($entry->post_content, apply_filters( 'avf_postgrid_excerpt_length' , $excerpt_length) , apply_filters( 'avf_postgrid_excerpt_delimiter' , " "), "…", true, '');
    

    .. replace it with:

    $prepare_excerpt = !empty($entry->post_excerpt) ? $entry->post_excerpt : $entry->post_content;
    

    Unfortunately, you can’t do this modification in a child theme.

    Best regards,
    Ismael

    #674076

    Great, thank you!

    #674558

    Hi,

    Glad we could help :-)

    Please let us know if you should need any further help on the topic.

    Thanks,
    Rikard

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.