Tagged: ,

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #13439

    Hey there,

    I read through the forum, but all solutions did not work for me.

    I simply want to use another google-font in my main menu, additionally to the “Heading Font” in the theme options.

    So 2 different google-fonts. One set in heading fonts (Antic), one set for my main menu (Amatic SC).

    So I installed both in the register-admin-options.php, set up “Antic” in my theme option and added following in my quick CSS:

    @import url(http://fonts.googleapis.com/css?family=Amatic+SC);

    .main_menu ul {
    font-family: font-family: 'Amatic SC' !important;
    }

    But the menu font is not changing at all. Am I missing something?

    The website is http://www.backtothegrindstone.de

    Thank you for your help and kind Regards,

    Phil

    #79258

    Little update, I put in

    @import url(http://fonts.googleapis.com/css?family=Amatic+SC);

    .main_menu ul {
    font-family: 'Amatic SC' !important;
    }

    But that did not work too. :(

    By the way, any other standard font like “verdana” or “arial” works, but none of the google fonts.

    #79259

    Okay I fixed it by putting the line

    @import url(http://fonts.googleapis.com/css?family=Amatic+SC);

    into the style.css file. Although it is not recommended to edit this file, nothing else worked.

    It seemed the @import function was not overwritten or accepted by the custom.css nor the quick css.

    #79260

    Withdrawal – safari screws it up, did only work for firefox.

    Now I am back to zero…

    #79261

    I use this plugin for google web fonts:

    http://wordpress.org/extend/plugins/wp-google-fonts/

    You can add custom css within the plugin to identify the element you want to change

    #79262

    Sounds good, I will give it a try.

    Appreciate your help! :)

    #79263

    Works perfectly, thank you a lot!!!

    #79264

    Hi philo,

    Glad that it worked. :)

    Thanks alan_82 for helping out. :)

    Cheers,

    Ismael

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘main menu google font change not working’ is closed to new replies.