Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #11055

    I couldn’t post this in the other thread because it’s closed.

    The problems demozeno was having might be MAMP related. SInce it’s an offline emulator it’s very hard to know how it was set up, but I use it sometimes and there are a couple of things I had to correct to solve some problems.

    1. Give the php more memory. It’s set in MAMP to be about 32MB. Put it up to at least 64MB

    2. Make all the permissions writeable and readable (basically tick all the check boxes)

    When you go from MAMP to the online site, it’s very important to remember to change all the offline urls to the online ones, and tell the database file to rename all its internal links also.

    You have to change your wp-config.php settings, change any urls in any .css or .php files that have been custom modified, and most importantly correctly export, reconfigure and import the database file into the new site with the internal links amended (the database file is a .sql file that you export using phpmyadmin). You can do it with a search/replace in any text editor but the tool below does a much better job on big databases.

    When your exported database file gets near 10mb you may have to import it using the terminal as phpmyadmin doesn’t like big files.

    This tool is really handy to import your database files correctly: searchreplacedb.php. You can get it from here:


    Hello Rumblefish

    Regarding your first point about MAMP, it is a likely culprit for not loading the theme properly, but can you be a little bit more specific as to where in MAMP I can manage the changes you suggest.

    Second, I did have real problems migrating the site from local to external host – with links referring back to local host and no header – tried a million solutions before realising it was to do, as you say, with the URLs not migrating and staying in local host. I came across the tool you suggest, but there is also a plug in I found in the WP Dashboard that does the same thing – called Search and Replace – and this seemed to work.


    In FILE / EDIT TEMPLATE / PHP of the MAMP user menu you can edit the template of the php version you are using. I think you change the setting of memory_limit to whatever you need. There are other settings too that you can adjust, like max post size etc.

    You change the permissions in the MAMP interface. Where there are two buttons Server and Host, click Host and then click the permissions button under Disk Location. That opens up the permissions panel and you basically check all the little check boxes so that MAMP can write to all the files it needs to.

    As far as the black screen. I had something similar happen when I installed WPML (translation plugin) for the first time. Then I realised that it was because the new language version didn’t have any content set up, so the site couldn’t display it. Hence the truncated display. You might have something similar. Perhaps you didn’t set up the blog template correctly, or your posts weren’t published correctly.

    Hope that helps. You can find most things in Google. There is usually someone who has gone through a similar problem. That’s how I found out the things about MAMP.


    I was using the free version of MAMP, which is why I wasn’t able to manage the changes you suggest. However, even after I set up MAMP Pro on trial and did go through your suggestions – increased memory, ticked permissions boxes – still having problems loading posts in slider. It’ll display up to 52 posts, but anything more than that, it won’t load and the blog is just black. I’ve tried fiddling about with posts to see if it’s a corrupt post, but it doesn’t seem to be one or two posts throwing a spanner in the works; it’s the volume of posts it doesn’t seem to like. It’s not the end of the world; it just means I can’t use the theme on local host and test it there and I’ll have to build up the website online – unless anyone knows another way. A test site would have been nice.

    Thanks for the help.



    Have you tried other apache servers like xampp: – I’m using it for windows but you can install it on MacOS/Linux too.

    Best regards,



    Well you could always just reduce the number of posts in the slider. 52 seems a hell of a lot to me.


    I personally don’t even use it. You can create your own slide shows with the template builder.

    Did you check if you have any plugin conflicts? Sometimes those can bugger up your theme. Or maybe just try a clean install of everything, now you have a version online.


    Hi demozeno,

    You can also build the site in a sub directory and then point the site there once you are ready to go live. As for the issues with MAMP, I’m not much help as I’ve not used it :)




    I think I’ve figured out what the problem was with loading the theme in local host with a lot of posts in the Features Sliders. It’s to do with a plug-in – specifically the WP-typography plug in. When I deactivated this plug in, the blog was loading fine again! I’ll give it a couple of days to see it wasn’t a fluke, but I had problems with this plug in on the external site – it slowed everything down – which was resolved by deactivating the plug-in. In fact, I noticed that the plug-in author knows the plug-in slows everything down and recommends only using it with another plug in– WP Super Cache.


    Thanks for the update :)

    I’ll keep that in mind as I had not heard of the plugin causing the issue before.

Viewing 9 posts - 1 through 9 (of 9 total)

The topic ‘MAMP issues’ is closed to new replies.