Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
    Posts
  • #5539

    Hi. I have your Shoutbox theme, just purchased it, installed it easily, and it is great. First, I want to thank you for such a great looking theme.

    I have the MapPress plugin installed, and I have various maps that I insert into bottom my posts. However, there seems to be a problem.

    For example, in one post, I do have a featured image set and all is great. I then go and inset a map location into the bottom of the post. When I am in the single page view, all is great. But in the archive page or in the main page etc… the map image gets shown in place of the featured image and the small box extrends longer verticaly. I have to remove the map for it to work and show properly.

    Any ideas?

    #50765

    Hey,

    please try following. Open up shoutboxframeworkphpfunction-set-avia-frontend.php and replace:

    if($post->post_excerpt)
    {
    $excerpt = get_the_excerpt();
    }
    else
    {
    $excerpt = preg_replace("![.+?]!", "", $post->post_content);
    $excerpt = avia_backend_truncate($excerpt, $length," ");
    }

    with:

    if($post->post_excerpt)
    {
    $excerpt = get_the_excerpt();
    }
    else
    {
    $excerpt = wp_filter_nohtml_kses( $post->post_content);
    $excerpt = strip_shortcodes( $excerpt );
    $excerpt = avia_backend_truncate($excerpt, $length," ");
    }

    #50766

    Thank you. This solved the singe page view. Now image shows at the top, and map shows in the post. But in the archives page, or when viewing category or tags, the box gets extended and the map also shows partially at the bottom. Can this be corrected too?

Viewing 3 posts - 1 through 3 (of 3 total)

The topic ‘mappress plugin and image issue’ is closed to new replies.