Viewing 12 posts - 1 through 12 (of 12 total)
  • Author
    Posts
  • #171652

    Hallo,

    Love your theme. However I need to add addtional product info for which I am using an extra tab which is working just fine. Within this (tab) content I am using a short code from Maps Marker. The map is not loading correctly. For your information I used this methode with your theme Abundance and it worked just fine.

    You can have look at the following product and click on the tab “Producent” you will see that just a part of the maps loads

    For your information the map loads just fine in a normal page:

    Thanks for your help
    Glenn

    #172902

    Hey Glennbosch!

    I marked this thread for Kriesi. The issue was discussed in the past ( http://www.kriesi.at/support/topic/google-map-issue-with-shortcode-tabs/#post-52423 ) and I’m not sure if he already found a solution. One workaround would be to reorder the tabs and to set the google maps tab as the first tab.

    Best regards,
    Peter

    #173006

    Hi Dude,

    Thanks for the link but I cannot find a solution. I tried to place the short code outside the custom tab but stil no result. Check this page .

    I seems that Kriesi has not come up with a solution but maybe I am missing something

    The thing is the short code works perfect within the Abundance theme. But I needed to switch to Replete because it is responsive. So it looks like a theme issue rather than a plugin malfunctioning.

    Thanks and regards,
    Glenn

    #173763

    Hi!

    Try switching to either twenty twelve or twenty thirteen and see if the map inside the WooCommerce tab works there. I’m not sure if its a theme issue or just in the way WooCommerce handles the tabs since Replete actually has less interaction with WooCommerce pages than Abundance does in order to give WooCommerce more control and flexibility with extensions.

    Regards,
    Devin

    #174095

    Hi Devin,

    Thanks for your suggestions. I am sure that you are aware that both twenty twelve and twenty thirteen do not have tabed product out of the box but info but show a listing. However I switch themes and the map did show up when I click on the appropriate listing link. You can check the screenshot here.

    Further I switched back to Abundace and the map showed up beautiful within the tab as it should. You can check the screenshot here

    For me it looks like a theme issue…

    Regards,
    Glenn

    #175079

    Hi!

    They actually both should have the tabs in the product. That isn’t a theme features, its part of WooCommerce.

    We’ll have to wait and see if Kriesi can reach out to the plugin author and get a copy to see what might be needed to be changed with Enfold since it shouldn’t be doing anything different with the product information in the tabs.

    Regards,
    Devin

    #175593

    Hi Devin,
    For your info I updated the map marker plugin to the Maps Marker® v1.3.1 – Pro Version. Nothing changed the maps are still not loading correctly.

    I also updated woocommerce to version: 2.0.16 still no improvement.

    The plugin I am using for the tab is: WooCommerce Custom Product Tabs Lite: Versie: 1.2.4 | by SkyVerge

    I hope Kriesi can come up with a solution to this (theme) issue.

    Thanks and regards
    Glenn

    #177312

    Hi Devin,

    I was hoping to get some kind of status update or even better a solution to my issue.

    Regards,
    Glenn

    #177699

    Hi!

    Looks like the only workaround right now is to put the Map outside the tabs.

    Cheers!
    Ismael

    #180434

    Hi Ismael,

    The map only works on a simple page but it does not work on a product page outside the tab. Once again it works great on your Abundance theme within the tab and outside the tab.

    So your workaround is not the solution, and YES I do need to show my map on the product page. So please come up with a fix

    Rgds,
    Glenn

    #180982

    Hey!

    Actually it seems to be a problem with the WooCommerce tab script which does not trigger a map resize. You can reproduce the issue with any responsive theme (i.e. the default TwentyThirteen theme) because Google maps won’t re-size correctly if percentage values are used for the map width. Abundance is not a responsive theme and thus the maps work properly. I created a ticket here: https://github.com/woothemes/woocommerce/issues/4014 and asked the WooCommerce devs to fix it. This is all I can do for now.

    Regards,
    Peter

    #182390

    Hi Peter,
    Good news, Robert the plugin developer from Maps Marker added a fix for this matter. The maps (shortcodes) from Maps Marker loads inside and outside the tab witout any problem. The fix he added is:

    – open /inc/showmap.php
    – find

    $(‘.ui-tabs’).on(‘tabsactivate’, function(event, ui) {

    and replace it with

    $(‘.ui-tabs, .tabs’).on(‘tabsactivate’, function(event, ui) {

    Then it should work.
    ========
    For me this issue is closed
    Rgds,
    Glenn

Viewing 12 posts - 1 through 12 (of 12 total)

The topic ‘Maps Marker’ is closed to new replies.