Tagged: 

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #28152

    I’m building a site for a customer (http://indigotest.com). They have one section that requires a mega menu that needs to hold about 75 items in five columns. I used your dummy pages to get the site started, but removed all the pages from the main menu and added my own items, including the mega menu. It was going fine and I was testing as I went along, but when I last updated the menu, ALL the dummy page items appeared in the menu again, and the mega menu (Seed Corn Selections) became a single strip. When I view the menu in the WP admin, none of the dummy items appear, but they appear on the website.

    Is there a maximum number of items that can be added?

    Thank you,

    Keith

    #136662

    We found the answer to this problem: Somehow we un-clicked the item at the very bottom of the menu page under Menu Settings that says, “Enfold Main Menu”. Once we checked this box again, the problem went away.

    #136663

    Apparently this did NOT resolve the problem. When we added the final seven entries to the menu, then saved the menu, the “Enfold Main Menu” box became un-checked again, so the same problem appears. We tried checking the box and saving it again, but it doesn’t work.

    Help!

    #136664

    Hey,

    Please contact your host, ask them to set the limit to 5000 for the following PHP values:

    suhosin.post.max_vars = 5000
    suhosin.request.max_vars = 5000

    You can also manually add this on your .htaccess file:

    php_value suhosin.post.max_vars 2048
    php_value suhosin.request.max_vars 2048

    Regards,

    Ismael

    #136665

    Is this an either/or suggestion? We added the second suggestion to the .htaccess file, but it didn’t help. When we add new items to the menu, it breaks, and we have to go to the Manage Locations tab, select Main Menu on the Enfold Main Menu option, and save again. It fixes the menu, but the items we added to the menu seem to be truncated.

    I spoke with our host facility about implementing your first suggestion, but they said making this change to the php.ini file will affect all sites on the server, which may cause problems for other sites.

    What would you suggest?

    #136666

    It should be possible to localize the change unless the server is very poorly set up.

    If you google either of the changes there are lots of articles explaining what it is the change is doing but the gist of it is you are telling the server to just accept more data per submission.

    Using something like Gravity Forms and a really big form I’ve had to up the suhosin.post.max_vars and suhosin.request.max_vars to 10000 so that it will process on the backend without issue and the same thing is happening to you with the wordpress menus.

    If it really is not possible I would recommend looking into moving to a new server.

    #136667

    Changing the php.ini file affected all sites on the server; the fix could not be localized to an individual account. But on the up-side, this fixed the problem so our menus look great again. Thank you!

    #136668

    Glad we could help :)

    Let us know if you have any other questions or issues.

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘Mega Menu Overload?’ is closed to new replies.