Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #23276

    Hi Guys,

    Have a simple question for you all. I was wondering if you can tell me how to properly find and define the font characteristics for the the:

    – Top Menu – and also with selected and hover

    – Sub Menu – and also with selected and hover

    I’m getting really confused on what to grab with firebug.

    Sorry for the noob question, but thank you very much for your help!!!

    – John

    #119177

    Hi,

    For the menu you can use this

    #top .main_menu .menu li > a {
    display: block;
    text-decoration: none;
    padding: 0 13px;
    font-weight: normal;
    font-size: 12px;
    font-weight: 600;
    font-size: 13px;
    font-family: Helvetica;
    }

    For the submenu, try this.

    #menu-sub-menu a {
    font-size: 15px;
    color: red;
    }

    Regards,

    Ismael

    #119178

    Ismael,

    the sub menu doesn’t seem to do anything.

    - John

    #119179

    Hi,

    What type of header are you using? Can you give me a screenshot of the submenu?

    Regards,

    Ismael

    #119180

    Not using the mega-menu… the header i’m using is the one with the navigation on the bottom logo

    #119181

    Hi,

    You should use this

    #top .main_menu .menu li ul a {
    width: 100%;
    height: auto;
    float: left;
    text-align: left;
    line-height: 23px;
    padding: 8px 15px;
    font-size: 12px;
    min-height: 23px;
    max-width: none;
    text-decoration: none;
    }

    Regards,

    Ismael

    #119182

    Oh that’s perfect, thank you!

    separate note —

    I can’t get the hover state to work properly. I tried the following cods and it didn’t do anything:

    hover state:

    #top .main_menu .menu li ul a:hover {

    active state:

    #top .main_menu .menu li ul a:active {

    Thanks bud

    #119183

    Hey!

    Did you try to add !important to your code like:

    #top .main_menu .menu li ul a:hover {
    color. #000 !important;
    }

    Best regards,

    Peter

    #119184

    Thanks Peter… I’ve got everything working great but the active states. IF thats what it’s called. When your on the page, I want that menu item only to be bold.

    - John

    #119185

    Hi,

    I think this is what you want.

    .active-parent-item a {
    color: red !important;
    font-weight: bold !important;
    }

    Regards,

    Ismael

    #119186

    Hi Ismael… unfortunately that code is working. I’ve got my site up and running so you can view it directly:

    http://www.tfgsearch.com

    For example when you come to the site, I’d like the first menu option “welcome” to be bold / black. Then congruently for each page that’s active that page would be bold / black.

    Hope that makes sense for what I’m trying to do.

    - John

    #119187

    Hi,

    Use this.

    .current-menu-item a {
    color: blue !important;
    font-weight: bold !important;
    }

    Regards,

    Ismael

    #119188

    Ismael,

    Unfortunatley that didn’t work either. Any other thoughts?

    #119189

    Hey!

    Try following code:

    #top .main_menu .menu li.current-menu-item > a
    font-weight: bold !important;
    }

    Best regards,

    Peter

    #119190

    :( didn’t work. I also added the beginning bracket after the A, so it’s not that either.

    #119191

    Hi,

    This really works. Please don’t remove the !important.

    .current-menu-item a {
    color: red !important;
    font-size: 20px !important;
    font-weight: bold !important;
    }

    This is what I see, when I apply the code above. The current page is “Welcome”.

    Regards,

    Ismael

    #119192

    I believe you, unfortunately the code isn’t doing anything :( Not sure what to do. I’ve tried putting it both in my custom.css and the Quick CSS. No change either way

    #119193

    Here, i’ve uploaded my custom.css. I don’t think there’s anything in here that would conflict, but you’re welcome to take a look at it.

    http://cl.ly/P4w5

    #119194

    Hi,

    Do you have a cache plugin? Flush the cache settings. Remove browser history then reload the page.

    Regards,

    Ismael

    #119195

    Bingo, that did it.

    Thanks Ismael.

    #119196

    Glad that Ismael got you back on track!

    Thanks,

    Nick

Viewing 21 posts - 1 through 21 (of 21 total)

The topic ‘Menu Font Changes’ is closed to new replies.