Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #29028

    Gday Kriesi forum

    I’m using Enfold 2.0.1 and WordPress 3.6, and have a primary menu of approx 80 items.

    When I add a new item, the system is automatically setting it as a custom mega menu, and knocks out my menu location.

    If I ignore that, and instead add more menu items, upon saving the menu it truncates back down to the original amount of items.

    I have all plugins turned off, with the exception of Tribe Events Calendar. Turning it off disabled my admin menu access altogether.

    Here is a 3 minute screencast showing the issue: http://screencast.com/t/SBbq7aq10k

    I’m pretty desperate as I intended to go live today, any help would be much appreciated.

    Any Kriesi admins that would like access to the installation, please send me your contacts and I’ll make you a user.

    cheers

    Darryl

    #139484

    Hi,

    Edit .htaccess or you can edit it yourself. Add this code:

    php_value suhosin.post.max_vars 2048
    php_value suhosin.request.max_vars 2048

    You can also ask your host to change the limit of these values for PHP.

    suhosin.post.max_vars = 5000
    suhosin.request.max_vars = 5000

    Regards,

    Ismael

    #139485

    You awesome thing Ismael, thanks for helping here!

    I have added the .htaccess information and get an Internal 500 Error

    Is the second set of code meant to be done as well (by the host as you say)? or were you saying it can be an either/or situation?

    This is my current htaccess code:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /~turabeac/
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /~turabeac/index.php [L]
    </IfModule>

    # END WordPress

    # Fix Enfold menus
    php_value suhosin.post.max_vars 2048
    php_value suhosin.request.max_vars 2048
    # END Fix Enfold menus

    cheers

    Darryl

    #139486

    Sometimes it’s not possible to overwrite the php settings with the htaccess file. If the htaccess code gives you an server error I’d suggest to contact the server administrator/hoster to change these values in the php.ini. More details can be found here: http://www.wpbeginner.com/wp-tutorials/how-to-fix-the-custom-menu-items-limit-in-wordpress/

    #139487

    Thanks for your help with this guys. Once the host made those changes, enabled suhosin and updated to php 5.4 it works like a charm. Much appreciated.

Viewing 5 posts - 1 through 5 (of 5 total)

The topic ‘Menu havoc – items auto assigning, items disappearing, location changing’ is closed to new replies.