Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #24079

    Hi, how can i fix this: the menu is overlapping into the logo in the ipad version,

    you can see it at:





    The menu should switch to dropdown or sliderOut Menu when viewing on an iPad. Check Enfold > Header > Responsive Header Main Menu.

    Also, please check Enfold > General Settings > Responsive Layout > select Responsive Layout.





    prefs are already at responsive header and responsive layout default (max with 1030px)…


    Seems as if your menu items are slightly too long. That´s why the menu overlaps a little before it changes to the dropdown. You could fix that by making your menu a little shorter but that can only be a quick fix I think. I would expect the menu to move under the logo if it becomes too wide (or the screen too small)



    @Michael Oeser: Thanks for the tip. I think it is a good idea.

    @purstodio: You can use Media Queries to target the iPad view.

    @media only screen and (min-width: 768px) and (max-width: 989px) {
    .responsive .main_menu ul > li > a {
    font-size: 11px;

    Add the code on your custom.css or Quick CSS.





    I tried the Quick CSS code provided but it didn’t help. I also checked the default settings for Header and General, as suggested. When in portrait mode, the menu slides under the logo and it partially blocked. Any updates? Thanks for your help!



    Please give us a link to your website. Maybe, you have a lot of menu items.




    Hi Ismael,

    Thanks for the reply! Here’s the link:


    Hi Venom – I think your logo is simply too big (should be 200 x 100 px)


    Try following – open up enfold/js/avia.js and search for

    if(first_level_items > 8 && !bottom_menu)

    Replace “8” with a lower value (eg “5”) and the theme should switch to the mobile menu when the user resizes the screen to < 1000px.


    Thanks for the suggestions! I’ll try them and hope it works.

Viewing 11 posts - 1 through 11 (of 11 total)

The topic ‘Menu overlapping on the logo (ipad)’ is closed to new replies.