Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
    Posts
  • #6835

    Hey Guys,

    I just noticed that the slideshow control buttons for the blog posts are not ranged to the right hand edge of the post, like they are on the fullwidth slideshow. How can I position them to permanently align with the right hand edge?

    Thanks

    rich

    ps. There is still a bug with the play control also. It remains as the pause button after first using it.

    #55644

    Hey,

    you can change the position with following code:

    .arrowslidecontrolls .ctrl_fwd {
    right: -35px;
    }

    .arrowslidecontrolls .ctrl_play {
    right: -5px;
    }

    .arrowslidecontrolls a {
    right: 25px;
    }

    By default the values are 0, 30px and 60px.

    #55645

    That’s funny, I actually tried exactly that css fix with Firebug, but I wasn’t sure if it would affect the fullwidth sliders too.

    Okay, I’ll give it a go!

    :O)

    Any ideas why the play button sticks?

    Thanks Dude

    #55646

    Hey Dude,

    For the small blog slide controls it’s actually:

    .arrowslidecontrolls .ctrl_fwd {

    right: -36px;

    }

    .arrowslidecontrolls .ctrl_play {

    right: -6px;

    }

    .arrowslidecontrolls a {

    right: 24px;

    }

    But I’ve just noticed now that it shifts the slide controls on the full width sliders too far to the right (they appear off the post now). There must be something in the code which positions the full width slide controls differently.

    #55647

    I could only find the style rules given above. Slideshow.css (or in your case: http://sos.cameratruck.es/wp-content/themes/shoutbox/css/slideshow.css ) contains the three rules (plus an extra rule for 5 columns layout only).

    #55648

    But do the full width controls shift for you, can you reproduce the same behaviour? Because if not maybe I have changed something in my custom.css wihout realising it affects these elements too. Seems odd though.

    I’ve changed the theme around a lot, but I’m pretty sure the blog post slide controls and the full width slide controls are in different positions in the theme as it is sold.

    #55649

    Yeah something’s definitely weird. I installed a default theme to make it easier to see. Here you can see the default fullwidth slide controls ranged to the right:

    http://box.cameratruck.es/?p=9

    and here the default smaller blog posts with slide controls further to the left:

    http://box.cameratruck.es/?p=282

    But the css positioning seems be the same, as you said. There must be something else nudging one to the left or one to the right by 36 pixels. Maybe its a margin or a float or something… I can’t find it!

    Here you can also see how the play button sticks on pause after you press it. Something’s wrong there too.

    #55650

    Try following code:

    .arrowslidecontrolls .ctrl_fwd {
    right: -35px;
    }

    .arrowslidecontrolls .ctrl_play {
    right: -5px;
    }

    .arrowslidecontrolls a {
    right: 25px;
    }

    .slideshow_full .arrowslidecontrolls .ctrl_fwd {
    right: 0px;
    }

    .slideshow_full .arrowslidecontrolls .ctrl_play {
    right: 30px;
    }

    .slideshow_full .arrowslidecontrolls a {
    right: 60px;
    }

    #55651

    That re-positioning for the full width slideshow buttons seems to work ok – Thanks!.

    The only thing, as I said before, is that the play button does not return once the pause button is pressed again. The sprite for the buttons isn’t being realigned or something…

    #55652

    Yes – I reported the problem to Kriesi – I think some other users reported this too.

Viewing 10 posts - 1 through 10 (of 10 total)

The topic ‘Move slideshow controls’ is closed to new replies.