Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #25579

    My menu is made up in a way that the menu items have no hyperlink behind them, but only the submenu contains all the pages. For that I added a custom menu item in the menu which contains only a # as the hyperlink.

    The problem with this is that people using a touch device can open the menu perfectly well, but it then stays open untill you actually click any other link. It doesn’t close after clicking the menu again, nor after clicking anywhere else on the page that is not a hyperlink. This means that people who once clicked the menu (accidentally or not) are stuck with a menu on top of their page content. Just another reason to close a website, of course.

    Is there something I can do to make it close again (like a timer, a close function when click away from the menu, or something else), please?

    It’s perhaps not really a question for the theme itself, but I thought I’d try asking here, too.

    #127473

    Hi,

    Clicking on something else closes the drop-down. On what devices does it not do that ?

    Are you making the menu item with # as a hyperlink as a custom link using only # for url and the button name in Appearance > Menus ( http://www.clipular.com/c?9495040=Tk54ZmUxeM4z7mVqt3mqIyDXjz8&f=.png )

    Don’t you have the mobile menu (drop down or slide-out) activated for mobile users?

    Thanks,

    Nick

    #127474

    Hi Nick,

    This is what I did:

    1) Create main menu with all the pages from the selection box on the left, as usual.

    2) Create 3 custom menu items with, indeed, a # as hyperlink so it doesn’t open any page by clicking on it.

    3) Drag all page items below it’s respective custom menu item.

    I have the mobile slide-out menu activated, but it is still the desktop menu on my iPad 2 in landscape mode. I do get the slide-out menu when turning to portrait mode, but not on landscape. Actually, I like it that way, it would be rather awkward to have that menu button in landscape mode as for me the menu fits perfectly well in landscape mode. I just need to find a way to close the menu again when you don’t want to click through to a another page.

    Let’s hope you find a fix.

    Thanks!

    #127475

    Hi,

    I will let Kriesi know, but I think for now a good idea would be to have ipad only deal with mobile menus until there is a solution. In file /js/avia.js find line 85 that looks like

    switchWidth 	  = 767;

    and change the 767 number to whichever width in pixels your version of ipad hits max on landscape view.

    do the same on line 1114.

    Thanks,

    Nick

    #127476

    Thanks, but I would really prefer to not use the compact menu for landscape tablet view. so some kind of deselect trigger would be REALLY helpful.

    Let’s hope Kriesi find a solution for this. Even if I do use this temporary solution for an iPad 2, it doesn’t fix the issue for Retina iPads, right?

    #127477

    Hi,

    I don’t own a retina iPad but I marked this thread for someone who does, and they will be able to answer better than I can.

    Thanks,

    Nick

    #127478

    Hi, I haven’t heard anything from this anymore. This issue still needs a fix though. Is there any alternative, like JS, please?

    I basically need something to tell the submenu to disappear again when the visitor clicks anywhere else. I see you add class names to custom menu items, so maybe I can use that to refer to in a JS script that generates the correct script to realize the toggle function?

    If you know of any JS function that would generate the toggle based on a class name, then just give me the link and I’ll even try it myself.

    #127479

    Hi DavyE,

    I would need to see your site live but from the description I think this is a flaw in touch devices in general. They have no hover effect and the browsers hack the way web code is rendered to provide fake hover options for certain things.

    Regards,

    Devin

Viewing 8 posts - 1 through 8 (of 8 total)

The topic ‘My menu not working well with touch devices’ is closed to new replies.